Lost remote access once changed Duplicati to run as a service

Hello there,
I m running Duplicati for testing purposes on many servers, all the jobs are set to backup to S3 and Local drive. It was running smoothly so far so, I decided to run Duplicati as a service (from Youtube tutorial). It turns out, I can`t access the Duplicati webpage from other machines now and only from the server itself ( I’ve searched for many ways to fix it, could not find anything helpful.

Below are the command I ran to make Duplicati available as a service.

cd “\Program Files”
cd “Duplicati 2”
(Then I ran) Duplicati.WindowsService.exe install --webservice-interface=loopback --webservice-port=8200 --portable-mode

I really appreciate any help,
Leonardo D.

I just had to remove the instruction “–webservice-interface=loopback” from Regedit (Duplicati Service). Remote access is working well again.

Regedit path

Image path
“C:\Program Files\Duplicati 2\Duplicati.WindowsService.exe” “–webservice-port=8200” --portable-mode

Welcome to the forum @leoofgold

The uninstall command followed by the modified install would likely have worked too.
I had thought services.msc could do it, but it doesn’t seem to. I’m glad you found a way.