Lost access and config after Windows Update?


I just noticed tonight that I cannot access Duplicati via web GUI on 2 separate PC, different sites. Both Windows 10 Pro and Duplicati installed as a service. One of the PC was asking for a new password, as if it was a new install. On a previous one, I thought I had put a wrong password so I tried the “–webservice-password=” thing but to no avail. Can’t access any of my backup profiles. Not sure what happened, Windows update broke something?

EDIT: I just confirmed that on a 2nd PC, after a first start of the GUI, it was asking me for a password, like new install, but I did not supply one, instead I closed the browser. Opening the page again now ask for a password and the one that worked this morning does not work anymore! I am the sole operator on these 2 units, not on the same physical site!

Your help would be appreciated!

Windows has this super annoying habit of moving the Duplicati executables to another directory during major updates and not moving them back when it’s done. If that’s the case, this forum post may help you to fix the problem.

1 Like


You ARE handy…! :wink: Thank you very much, that was exactly it! I apologize for not having found the solution myself; I did search the forum but it was around 02:00 in the morning my time and I was more or less not thinking clearly! I basically copied the Duplicati folder from windows.old to the current location and that didi it! Will now definitely look into the portable install “fix” solution!

Again thank you and happy holidays! :slight_smile: