Issue with Synology


#1

Hi, I’ve done a lot of searching and trial and error, but I’m done clutching at straws. I can’t get this to work.
I tried it on my Synology first, and it was fine, but then installing on another, it just won’t work.

I run the service, and as soon as I open Duplicati, I get the “Not logged in” error, and then the page could not be found from Synology. Opening the service in package center shows that it is no longer running.

I’ve tried the 3 lines of export and then running the service manually, and that errored with the directory not found, but I turned on user homes, and that is now resolved, but that comes back with this:
mono /volume1/@appstore/Duplicati/Duplicati.Server.exe --webse rvice-port=8200 --webservice-interface=any
A serious error occurred in Duplicati: System.Exception: Unable to open a socket for listening, tried ports: 8200
at Duplicati.Server.WebServer.Server…ctor (System.Collections.Generic.IDictionary`2[TKey,TValue] options) [0x002e2] in <670b0e4a9ae144208688fcb192d20146>:0
at Duplicati.Server.Program.RealMain (System.String[] _args) [0x00627] in <670b0e4a9ae144208688fcb192d20146>:0:

I was able to get into it ONCE, but after setting a password, I was kicked out and I can’t find the location of the lock_v2 file to delete it and try again.

I have uninstalled and reinstalled both Mono and Duplicati to no avail.

Mono is 4.6.2-0096

Any help would be appreciated.


#2

I should mention that it will run on port 8201, but then when I try to access it, I get an error saying the server has not been configured correctly, and same result, I’m kicked out.


#3

It sounds as if something is running and using port 8200 (could be an old instance of Duplicati). Did you try a reboot to make sure the port is available?

The lock file (and other stuff) is in /root/.config/Duplicati.

Can you post a screenshot or similar of the error saying the server has not been configured correctly?


#4

I rebooted the NAS, and I’ve run a netstat, but nothing appears on port 8200, hence suspecting the lockfile.

Access is denied to /root so I can’t even get in there to check for the lockfile.

I did manage to get it running after the reboot on port 8201 however and could configure a backup job, so the only thing remaining (I hope) is to somehow check and clear that lockfile. Any thoughts?


#5

After you ssh in, run “sudo bash” to open a root level command prompt. You’ll have to enter your password again. After doing this you can check inside the /root/.config folder.


#6

The lock file is using cooperative locking, so a reboot should clear the locks on the file, even if the file persist.


#7

Thanks guys,

The lock file didn’t fix anything. Here’s the current screenshot.

Loading it manually on another port seems to be a solution, but not the right one. I can’t have a client environment being unreliable, or requiring putty to be open on a computer 24/7 to hold Duplicati in a running state.

I also did another netstat. I can see port 8200 there listening… I’ll do a bit more digging to see what’s causing this.


#8

ok, so killing the PID allows it to be started manually. The password that I applied the first time is now asked for as opposed to port 8201, which I didn’t put a password on. Also the backup that I created with 8201 doesn’t appear. Also, I have to access it directly via URL :8200 on the browser, Duplicati doesn’t appear in the Synology menu

most of this isn’t a problem, as I want the password there, and I can recreate the backup job (which hasn’t been run yet).

Killing the PID and running it through the Package Centre still causes issues though, and I need it to start up automatically and be easily administrable.

Hoping you have some more ideas :slight_smile: