Installation on opensuse Leap 42.2 - is this supported?

Hello Team,

I decided to try duplicati for managing my backup. As I didn’t found a special package for my openSUSE Leap 42.2 I tried the Fedora / ResdHat rpm because opensuse is also rpm based.

During Installation via opensuses system management tool “YaST” the following dependency issue comes up:

This is though I have libappindicator installed:

I ignored the dependency, hoping for the best.

when I start duplicati from the command line I get the following response:
Server gestartet und hört auf, Port 8200 Request error: Unexpected error: System.TypeLoadException: Could not load type 'Duplicati.GUI.TrayIcon.GtkRunner' from assembly 'Duplicati.GUI.TrayIcon, Version=, Culture=neutral, PublicKeyToken=null'. at Duplicati.GUI.TrayIcon.Program.RunTrayIcon (System.String toolkit) [0x00027] in <d07129d6974642b0bbdaa3ccc42fe89d>:0 at Duplicati.GUI.TrayIcon.Program.RealMain (System.String[] _args) [0x0040e] in <d07129d6974642b0bbdaa3ccc42fe89d>:0

I tried to connect to with firefox but it cannot connect.

Is there a “known best way” for using duplicati with opensuse?

1 Like

I don’t know about a best way to install on OpenSuse, but I can confirm Duplicati does need libappindicator to drive the Tray Icon. And for some distros you might need to also install EPEL (yum -y install epel-release) before you can get to libappindicator.

Does anything in this topic help?

There is no package matching a search for epel in opensuse. But I think this is not the issue because I was able to install both available libappindicator packages.

In the meantime I figured out, that if I run duplicati-server instead of duplicati then I can open the duplicati page on http://localhost:8200.

Will continue playing !

That makes sense as duplicati-server doesn’t need libappindicator, only the tray icon does (to actually display the icon).

I’m glad you got the server working! Though I’m not sure why the tray icon is still not working even after you were able to install the libappindicator packages…

Are you interested in more information?
The following libappindicator files are on my system:

~> ls -l /usr/lib64/libappin*
lrwxrwxrwx 1 root root    25 31. Okt 15:48 /usr/lib64/ ->
-rwxr-xr-x 1 root root 52336  8. Okt 2016  /usr/lib64/
lrwxrwxrwx 1 root root    24 31. Okt 15:48 /usr/lib64/ ->
-rwxr-xr-x 1 root root 52336  8. Okt 2016  /usr/lib64/

In the meantime I did 2 test cases which seem to work, the third test is busy uploading.
Thanks for your work so far :+1:

Thanks for the additional information - unfortunately you’ve reached the limit of my libappindicator knowledge. :slight_smile:

It’s good to hear you’ve got test cases working! Hopefully somebody else who’s run into this will be able to comment on whether or not they got the tray icon working.

Thats fine, I don’t need the icon so much.

But another question: Shouldn’t be a systemd service file installed so the server can be started at system startup?

I found a duplicati.service file in the github sources
but not in the rpm package

Is this intentional?

Did you try the post about it from the CentOS 7 link above?

It’s not intentional so much as nobody has had the right combination of time and RPM skills to get it set up right. :slight_smile:

Ah, I understand - for now the service file has to be created manually. Thanks for pointing me to the CentOS post.
Unfortunately I also have rpm skills close to zero, so I cannot help :cry:

1 Like

The library that is needed for the tray-icon is called libappindicator-gtksharp and is the C# + GTK bindings to I assume this is what is missing, but I do not know what that package is called in the SUSE package system.

I have these two installed on TW and ignored the dependency warning. Works just fine:
i+ | libindicator3-7 | Panel indicator applet - Shared Libraries | package
i+ | libindicator7 | Panel indicator applet – Shared Libraries | package

1 Like

I installed libappindicator-sharp from CentOS on my Leap 42.3 machine, ignored the warnings and duplicati starts

1 Like

Good to hear! I went ahead and flagged your post as the solution to help any future readers get right to what worked for you.

Hi everyone. I switched to Opensuse Tumbleweed recently. I’ve been using Duplicati in Windows for quite some time so I would like to keep doing so with Linux. Unfortunately I can’t get it to run in Opensuse TW. I’ve followed the advice here but the package duplicati-server won’t start. Libappindicator is installed and so is the Duplicati package after ignoring the message that libappindicator is missing. Starting duplicati-server from terminal produces this error:

Unhandled Exception:
System.TypeInitializationException: The type initializer for ‘System.Console’ threw an exception. —> System.TypeInitializationException: The type initializer for ‘System.ConsoleDriver’ threw an exception. —> System.Exception: Magic number is wrong: 542

And lots more text after that. Please help. Has anything changed in the past few months that has broken the fix described here?

1 Like

It’s quite an old thread and frankly, currently given solution in this thread is nothing else but fabrication. I’ve to note as a matter of safety, no one should propose such a thing as solution, mixing and build packages from different distributions into unwary users’ OS
Is it planned to make Duplicati 2.0 for openSUSE, I mean ever?

1 Like