Installation on Hyper-V Server (core)

Hi everyone.

I’m new with Duplicati and really like as far as I’ve used it. Now I’m trying to install it on Hyper-V Server 2102R2 (core server) and I’m having problems with VSS. It installs and works OK but I cannot use VSS for backuping my VMs because of AlphaVSS.x64.dll dependencies. The problem is I’m not able (or don’t know how to do it) to install C++ redist, it always goes to an error.
I’ve tried several versions, installers, commands… no way to make it work.

Anyone has this configuration running and could help me with it?

Thanks a lot!

I’m not sure about how you’d get AlphaVSS on your machine, but a word of caution.

Duplicati performs very poorly in VM-disk backup scenarios. Changing a single file in your vm could potentially cause the entire VMDK to be reuploaded.

Thanks for your tip @Pectojin. We are using a NAS en the same LAN for virtual disk backup, so I really don’t care too much for that. I could even accept full backup every night (thats what’s happening now…). When talking about VM backup I only need Duplicati to access to this web interface and check everything is OK.

Any help on this please? I’m sure it has a way to be done!


Did you try verifying whether or not the files exist as described here?

Also, can you provide the actual Duplicati and / or C++ redist. install errors that you are seeing?

I ran into a similar issue with one of my fresh 2012R2 servers (for another project). You need to manually install the Microsoft service pack SP1 for the OS (it does not come in via Windows Update), then the C++ redist should install, and should be able to continue on.


Really? I’ll give it a try!

It worked!!! The exact update needed was KB2919355. After installation, reboot, reinstall C++ Redist, reboot again and… magic!

Thanks a lot @mikaitech for your tip!!!


The KB differs depending on if it is x86 or x64 although the bulk of the servers in use should be x64.
Good to hear it worked, enjoy.

Well, in my particular case of Hyper-V Server I think there’s no 32bit version at all :wink: