Incorrect starting time

I’m using duplicati (v. on a Windows server 2016 host.
The backups are scheduled to be launched every day at 22:30:

i.e 10:30 PM :

And yet, this backup started several times at different times:


Any idea why?
Thanks for your kind help.

Is it possible you have it installed in user mode (the default) and you are not logged in to the server at 22:30? If so, the backup will run the next time you log in.

If you installed it as a service, then we’ll need to dig a bit deeper.

For a server you most certainly want it running as a service. Note that migrating from user mode to service mode takes a bit of caution. We can provide more detail if it indeed is running in user mode right now.

Hi drwtsn32
Thanks for your quick answer.
Your hypothesis might be right, because I just logged into this server and the backup task just started.
How can I check if duplicati was installed in user mode? I guess it is, if it’s the default install.
Could you please tell me how can I migrate from user mode to service mode?

Thanks @drwtsn32 !
I followed this tutorial, everything went fine, except the database part.

I am facing those 2 error logs:

  • “Failed: database is locked”

  • “Failed: Found 379 remote files that are not recorded in local storage, please run repair”

I have of course tried the repair button, but the error messages are still there.

I had yet followed the tutorial, including the parts about the database:

  1. Move the file C:\Users\[your user name]\AppData\Local\Duplicati\Duplicati-server.sqlite to the folder you created in step 1, so that you end up with C:\ProgramData\Duplicati\Data\Duplicati-server.sqlite
  1. Use the “Move existing database” feature for each existing backup set
    Click on one of your backup sets to open its drop-down menu
    Click on “Database” under the “Advanced” heading
    Under the “Location” section, click in the “Local database path” field. (Note, the buttons underneath are grayed out until the path actually changes.)
    Replace the text C:\Users\[your user name]\AppData\Local\Duplicati\ part with C:\ProgramData\Duplicati\Data\ , leaving the XXXXXXXXXX.sqlite part alone. So you’ll end up with something like C:\ProgramData\Duplicati\Data\ABCDEFGHIJ.sqlite
    If this backup set has already run at some point, click “Move existing database”. If the move button is disabled because the backup hasn’t run yet, click the “Save” button instead.
    Repeat these inner steps 1 to 5 (8.1. to 8.5.) for any other backup sets you have

My settings seem good:

What am I missing?
Thanks for your kind help.

This tells me the job specific database wasn’t moved properly. But maybe it doesn’t matter too much. What message did you get when you tried Repair?

Can you confirm that the user instance of Duplicati is no longer running and you only have the service instance?