How to give duplicati root permision on ubuntu

I’ve setup a backup on my ubuntu linux computer. Most of the files backup, but any file my user id doesn’t have read permission for fails. Can some one walk me through how to grant duplicati root permission for doing backups?

I think the simplest is to run Duplicati as a service:

  1. Stop any running instance
  2. Run sudo systemctl start duplicati
  3. Change the desktop launcher shortcut to duplicati --no-hosted-server --serverurl=http://localhost:8200
  4. Start the desktop launcher

This will run Duplicati as a service (on boot) and only start the tray icon once you are logged in to your desktop, but connect to the running service.



To be able to take advantage of my original backup I exported my configuration to file and then imported it after setting up root as you described. The first backup after that had a bunch of errors, but also said to run repair. Running repair seemed to fix everything up. My backup from last night was error free. I’m guessing I’m good after the repair. But figure I should ask, any reason I’m better off blowing away all the backups and starting fresh using root from the start.

Depends on what the error messages were.

But maybe there was a problem accessing the local database, as the databases are created under the user’s home folder. Repair will recreate the database, so maybe that is what happened.

this was the error I had before repair

Duplicati.Library.Interface.UserInformationException: Found 10965 remote files that are not recorded in local storage, please run repair

BTW: A good way of showing your appreciation for a post is to like it: just press the :heart: button under the post.

If you asked the original question, you can also mark an answer as the accepted answer which solved your problem using the tick-box button you see under each reply.

All of this also helps the forum software distinguish interesting from less interesting posts when compiling summary emails.

That means that the local database is empty, and the remote destination contains 10965 files. You should delete the local database and then run repair to rebuild it from the remote data.

1 Like

Hi, i’m confused by this. I tried it and it doesn’t start Duplicati at boot - it works perfectly well, until i reboot. It’s also using the TrayIcon which i would have thought would be unusual for an app run ‘as a service’. Does it work for the OP? Am i doing something wrong? I would have thought something else is needed, either a command configured to run at boot/login either through the UI or a config file somewhere.

EDIT - just found this:

Should it actually be:
$ sudo systemctl enable duplicati
$ sudo systemctl enable duplicati.service
…rather than “start”?

Either seems to work, not sure if there’s a difference :slight_smile:

1 Like

Yes, I think that is correct. Using start will only start it now, and enable will add it to the boot sequence.

I think you can choose both duplicat or duplicati.service.

1 Like