How do I tell an S3 backend the exact region to use?

I am using my own S3-compatible Minio backend and I had to set its region for another reason. But now Duplicati balks at the changed region. I’d like to set the exact region string for Duplicati to use. How can I do that?

Nobody? I’m running into problems because a MinIO backend (S3-compatible) is used by two frontends, one of which is Duplicati. The other demands a region setting on MinIO, but as soon as I set the region, the Duplicate backup fails.

Does the below help? I don’t use S3… Yes, it says “create”, but it’s the only region I see.



As a side note, the current Beta S3 client is Amazon’s, but MinIO’s client is in next Beta.

View from Release: (experimental) 2020-01-03

The problem I’m having is that my MinIO had not configured a region at all and that worked (only Duplicati was using it). But the other software using the same MinIO storage apparently checks for and requires a non-empty bucket region when it checks. So, I did set it to a value in MinIO (my home town). Then the other software worked, but it made Duplicati fail.

Do the Duplicati region settings I showed help or not? I was hoping to hear specific results from a test, which might actually be two tests if you try the MinIO client to see if it works any better than Amazon’s.

Ideally result would be a success because my S3 expertise ends with your typing the desired region…

Not sure what the region is doing with MinIO. For AWS hosted S3 buckets, the region parameter is only applied when creating the bucket, and ignored otherwise (it is also used in Duplicati to choose the host to send data to, for efficiency reasons). For AWS buckets, you can just create the bucket using the AWS console, and then ignore the region setting afterwards.

The way I understand MinIO, you are hosting it yourself, so there really is just one region (the machine running MinIO). It would help if you post the exact error message, but generally, I think you should not set a region for MinIO targets.

it is also used in Duplicati to choose the host to send data to, for efficiency reasons

That could be it. I need URL-style and not host-style addressing. If Duplicati changes the host when I enter a region, the DNS will not resolve.

I will create a region minio and see what error message I get.

Another idea from the forum. You can look at the original issue and symptoms to see if it matches yours.

That worked. I should have tried that in the first place.

1 Like