How can I disable start of missed backups when duplicati start?


#21

The way the queue works it should not add a job that already is in the queue.

Assuming things are working as they should, the worst case scenario would be:

  • job A is active & running past the next start time so
  • job A is added to the queue (which contains only non-running items)
  • job A is on the schedule for a future run

With frequently scheduled jobs that tend to run long, this makes it like the job or just running on a loop.

On the bottom of the About -> System info page there’s some JSON formatted text that includes what’s currently in the queue. If you can paste that here showing a job listed more than once, that would be great.

Of course that’s how it’s supposed to work now,that doesn’t mean there isn’t potential for future changes. :wink:


#22

I too would like the option of rerunning missed backups. Other backup systems that I use, bareos, support this. I agree that the default behavior of Duplicati should not change in that missed backups should be run immediately. However it would be really nice to have the option to disable this for those of us that have specific reasons.

In most cases I want the default of rerunning missed jobs immediately. However I have a system that runs backups daily and may be offline when the last backup should have run. In this particular case I just want the system to wait until the next scheduled time to start the backup, otherwise Duplicati will be much of the day, since a single backup takes 2.5 hours.