High Sierra client won't run; Duplicati repeatedly crashes with "KeyError: 'Text'"

On a freshly installed High Sierra client, I installed brew, tried to install Duplicati (but the URLs are wrong so it fails), so I grabbed the package from the Duplicati site for the most current canary version: v2.0.4.8-

Immediately upon install, my dock does a spastic jig as a python app repeatedly tries to run. When I run Duplicati from the command line, the following is logged.

$ /Applications/Duplicati.app/Contents/MacOS/duplicati
Unexpected message: None
Unexpected message: Exception in thread Thread-1:
Unexpected message: Traceback (most recent call last):
Unexpected message: File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py”, line 810, in __bootstrap_inner
Unexpected message: self.run()
Unexpected message: File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py”, line 763, in run
Unexpected message: self.__target(*self.__args, **self.__kwargs)
Unexpected message: File “/Applications/Duplicati.app/Contents/Resources/OSXTrayHost/osx-trayicon-rumps.py”, line 108, in get_input
Unexpected message: app.menu = parsemenus(cfg)
Unexpected message: File “/Applications/Duplicati.app/Contents/Resources/OSXTrayHost/osx-trayicon-rumps.py”, line 51, in parsemenus
Unexpected message: mn = rumps.MenuItem(n[“Text”])
Unexpected message: KeyError: ‘Text’

I’ve tried removing everything related to Duplicati (I did a filesystem-wide search with find for anything with Duplicati or duplicati in the name), including .config/Duplicati.

I’m currently dead in the water waiting on this to be fixed before I can do a restore.

Edit: standard python version:

$ python --version
Python 2.7.10

Edit 2: same issue with
Edit 3: no such issue with