High CPU usage, nothing running

I was getting high CPU load alerts from my Duplicati system ( on Ubuntu 18.04) all day, which is unusual unless a backup is running and doing a lot. Backups seemed to be running OK but when I got home I saw Duplicati.Server.exe using 80% of CPU across two processes. The problem is, Duplicati wasn’t doing anything at the time. There was nothing in the syslog, and nothing in the profiling log on the web interface. The next scheduled job was an hour away.

I issued “service duplicati restart” and those processes went away, and my load average dropped dramatically.

I don’t know if there’s a way to tell what Duplicati is doing when it’s not technically supposed to be doing anything, so maybe there’s a system level log I can enable in case this happens again so I can look into it further?

Quick edit - this was saved in my drafts for several weeks and happened again today. I’m going to leave the Duplicati.Server.exe process running, taking ~40% of CPU, in case anyone has any diagnostic suggestions that might benefit from having it running in this state.

Hello, which version of mono are you using?

mono --version reports

I have had this happen before. I don’t know the root cause. I ended up stopping the Duplicati service and restarting it. I don’t think I’ve had it happen again…

It’s happened a couple of times now so I figured I’d mention it and see if anyone had any suggestions. I’d like to investigate but without any logs or diagnostics I don’t know what to do.

May be this issue:

I’m having the same issue. Nothing running and Duplicati server using a huge amount of CPU.

Mono: Mono JIT compiler version 4.6.2 (Debian

For me it’s pretty consistent. There appear to be over 30 Duplicate.Server.exe processes running.
I had to disable it so I could get some work done!

I am running Duplicati using systemd, so it runs automatically.

Yikes, having over 30 Duplicati processes running is not normal!

First thing I’d do is upgrade your version of Mono. Duplicati 2.0.5.x requires Mono 5.x or newer (the dependency was not set properly in the release, unfortunately).

First make sure Duplicati is not running:

$ sudo systemctl stop duplicati

Follow the installation instructions here for Debian:

Then restart the Duplicati service and see if it works any better for you:

$ sudo systemctl start duplicati