# Getting timeouts/database locks on restore screen

**URL:** https://forum.duplicati.com/t/getting-timeouts-database-locks-on-restore-screen/13751
**Category:** Support
**Created:** [January 14, 2022, 6:55pm UTC](https://forum.duplicati.com/t/getting-timeouts-database-locks-on-restore-screen/13751 "2022-01-14T18:55:27Z")
**Posts on this page:** 1
**Showing post:** 12

<div class="post-metadata">

### Author: ![ts678](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/t/8491ac/32.png) [@ts678](https://forum.duplicati.com/u/ts678)
#### Post date: [January 15, 2022, 10:09pm UTC](https://forum.duplicati.com/t/getting-timeouts-database-locks-on-restore-screen/13751/12 "2022-01-15T22:09:56Z")

</div>

[Failed to connect: Gateway Time-out issue when restoring](https://forum.duplicati.com/t/failed-to-connect-gateway-time-out-issue-when-restoring/12666/8) was me on how to increase the NGINX timeout, however in that topic it turned into a different error. For awhile though you weren’t on NGINX. Are you back?

> [@zneumann](#):
>
> Currently, I am trying to do the same restore by importing the config file on my local machine (and grabbing the files remotely) and even that was throwing the same errors for a while.

The network status code image with the 504 is gateway timeout. Is that what you’ve always been getting? Talking about timeout in a generic way leaves too much guessing, so I was trying to get timeouts clarified.

I am not certain that the Duplicati web server can’t 504, but I doubt it. I don’t see a 504 or GatewayTimeout from a [source](https://github.com/duplicati/httpserver) search. I do see it returning a lot of its errors using the names from [HttpStatusCode Enum](https://docs.microsoft.com/en-us/dotnet/api/system.net.httpstatuscode?view=netframework-4.8).

You can watch the SQL go by in About → Show log → Live → Profiling (if that web report stays .working).  
More certain (and more setup) is [log-file](https://duplicati.readthedocs.io/en/latest/06-advanced-options/#log-file)=\<path\> and [log-file-log-level](https://duplicati.readthedocs.io/en/latest/06-advanced-options/#log-file-log-level)=profiling, then `tail -f` your log file, while also watching for a 504. Possibly you’ll see it still in the query when NGINX gets tired of waiting on it.

If the problem is really that the response can’t meet the timeout, the only short-term fix is to raise timeout.  
Note that this theory doesn’t hold too well if you’re on a direct network path to localhost:8200 (if you were).

---

_[View the full topic](https://forum.duplicati.com/t/getting-timeouts-database-locks-on-restore-screen/13751)._
