Getting started: setup and destination issues

I just installed Duplicati on a Raspberry Pi 3B+ running Buster (Linux 10). It has two LAN connections, one to my wired LAN (10.0.5.1) and the other to my Netgear WIFI LAN (192.168.59.1). Installation went smoothly with no error messages.

Right now I’m trying to get familiar with this program. Spent some time doing test backups and was not successful getting to the USB drive on my Netgear router nor to a SAMBA share on another Pi. BUT it also did not throw any errors, if fact seemed to say that all went well?? “Test Connection” test worked and in one case said that it created the non-existent BU folder, but did not! It did work for a USB stick attached to the Pi running Duplicati.

I don’t see how to attach a screen shot of the “Destination” set up page which shows the paths to the above failed. Here are those entries:

  • \\192.168.59.115\usb\output\BU
  • \\readyshare\Netgear_4TB\BU

Also, how can I clear the above paths from the “Destination” setup page?..Thanks…RDK45

I tried in under Windows and had no such problem to connect (to a Linux based NAS) , creating a directory and backing up a few files. Maybe you are using Docker ? This has some weird rules with permissions that I’m not familiar with. In this case try a direct install.

copy/paste works for me. You can also use the upload button (the up arrow) to select an existing file. This is under Kubuntu 22.04. Try another browser maybe ?

I tried it and if you entered the path manually, when modifying the job the manual path stays enabled, so you can enter another path or I don’t understand what you are trying to do ?

@gpatel-fr …Thanks for you efforts and comments.

I’m not using Windows, this is a new Buster install on a Raspberry Pi 3B+, but running the Duplicati web GUI over the LAN from Firefox on a Windows PC. No Docker.

Regarding the paths in the “Destination” section, I have experimented with several backups and destination paths which I will not be using again and do not want them to continue to show when I working on a new backup, see the attached image.


So I would like to be able to delete/remove them.

then go to your Pi (or ssh to it), cd / and rmdir ‘\192.168.59.115\usb\output\BU’ should do it.

I do not understand?? Which issue are you addressing? More details please?..RDK

you want to delete the directories that your attempts at creating backups have created at the root of your Pi file system, so I say to use rmdir.

Thanks. OK, I’ll give it a try…RDK

@gpatel-fr …Are are a genius, I did not realize that the Destination setup created those folders. That worked.

Now I have to figure out why my trial backups using the above network paths are not transferring any files, and do not throw any errors…RDK

Try to check that Samba is working correctly on your Pi. Samba is not easy to setup, I cheated by using Windows where a special version of Samba is used that usually is working without changing configuration files.

@gpatel-fr I cheat also, I first installed SAMBA about 8 years ago with one of my first Pi’s. At that time there was a web GUI for SAMBA called SWAT. Not long after that the developers stopped supporting it and then it was declared “deprecated”. But, by then I had a conf file which did what I wanted. I have built many Pi’s since then, I just install SAMBA, copy my conf file over the default file, set up passwords and make sure the mount statements in fstab support access to the USB stick.
So to answer your question, SAMBA is working on this Pi.
Anyway, I was able to rmdir the first path directory \\192.168.59.115\usb\output\BU, but for the other one it threw an error that the folder was not empty. Sure enough there were three files in it with a data stamp about when I was doing some of my testing.

duplicati-20221014T143641Z.dlist.zip.aes
duplicati-b0cbcd937e10143c6a6ec87731d632835.dblock.zip.aes
duplicati-ic303d99470c94a38a5af9c9aa3a89683.dindex.zip.aes

So, were those the files which were supposed to be written to that Netgear share?

I have deleted those files and will try creating another backup file…RDK

yes, it’s a typical first (small) Duplicati backup - dlist is the file list, there is one per backup version.

OK, I’ve decided that I don’t understand how one sets up a backup to go to another computer or storage device on the local network (LAN). From Windows if I want to map a drive to a computer share the format would be

\\192.168.59.115\usb\output
or
\\readyshare\Netgear_4TB

with Duplicati when I manually enter either of the above, it creates a folder with the path text, but I don’t see that it then links it to the other computer/device for data transfer.

Thus I can only assume I’m doing something wrong in specifying the path to a file share on the LAN. Can someone help me?..RDK

maybe UNC don’t work with Samba and you need to mount the Samba shares.
Anyway, Samba is a huge pain generally and you would probably have less work by using Sftp. Just a thought.

OK, but the Netgear share is not SAMBA related. I’ll look into SFTP…RDK

What does that mean? You look like you’re using Universal Naming Convention which on Windows is how one accesses SMB shares. Linux doesn’t know UNC AFAIK, but Samba is how Linux gets to SMB shares.

A backslash on Linux is just a character. You can put it in a path, but it doesn’t make directories or do UNC.

# cd /
# mkdir '\\192.168.59.115\usb\output\BU'
# df '\\192.168.59.115\usb\output\BU'
Filesystem     1K-blocks     Used Available Use% Mounted on
/dev/sda1       20509264 14680360   4764048  76% /
# 

Duplicati would likely do similarly if you asked for that. You’d get an oddly named folder on the local drive…

Look at 11.5. Setting Up Windows Shares with Samba (Debian Administrator’s Handbook) and other sites.

If you can get set up so that share access is working for the user Duplicati uses, then have Duplicati use it. There is no built-in SMB support. On both Windows and Linux, Duplicati just uses it like a local file or folder.

EDIT:

Scripting options can be used if you want to mount for Duplicati, then unmount after. Or mount at boot time.
There might be other options. I don’t generally use Samba, so if anyone out there is expert, feel free to help.

I wonder if the confusion is the fact that you (OP) are running the Duplicati GUI from a browser on a Windows machine and so it seems that referencing them as Windows would reference them seems right. While you’re viewing the GUI on the Windows machine, Duplicati is actually running and accessing things via Linux on the Pi. To specify a “local” Duplicati destination, that destination needs to exist on the Pi, not on your Windows system. You need to mount your SMB shares on your Pi, then once they are mounted, you’ll see them in the Duplicati GUI “Destination” selection page.

Of course this is assuming that you want to do your backup “locally” like this (Any directories/folders addressable on the system, your Pi here, are “local” destinations even if they’re SMB mounts). SFTP is another option, as you’ve mentioned, but your destination system needs to to be set up to accept SFTP connections.

Great, this is turning into a real learning experience!!! Thanks to all of you for your comments and suggestion. As I said earlier:

Historically I have implemented SAMBA on my Pis so I could get to files on the Pi from my windows PC’s. That is working as I wanted. Until now I had never wanted to copy/access files to/from another PI, and thus had never had to “mount” a share on another Pi. Which if I understand your comments is what I have to figure out and do.

A Google search has lead me to this reference mount-a-network-shared-drive-on-linux. It is dated 2018. Is this moving me in the right direction?

Other suggestions and/or comments? Thanks again…RDK

While I did not try using the steps outlined there, generally speaking, yes, that page is a set of instructions to do what you need to do.

Note that the share will be accessible at the “mount point” vs in the way you’d see it from windows. So, for example, in this command from that page:

sudo mount.cifs //10.0.1.4/share /mnt/share/nmshare/ -o user=share,pass=share

Whatever is on the //10.0.1.4/share would show up in the directory /mnt/share/nmshare on your pi. So in the “Destination” page in Duplicati, you would see mnt → share → nmshare under “Computer”.

1 Like

It sounds like you already do 11.5.1. Samba Server but now want 11.5.2. Samba Client.

Debian man pages (forced to buster, but it’s old and the search wants me to look at bullseye):

mount.cifs mount.smb3 - mount using the Common Internet File System (CIFS)

The mount.cifs utility attaches the UNC name (exported network resource) specified as service (using //server/share syntax, where “server” is the server name or IP address and “share” is the name of the share) to the local directory mount-point.

(I guess one could debate whether that’s UNC or a Linux-adapted format using the Linux path convention)

mount - mount a filesystem (calls mount.cifs for CIFS/SMB)

fstab - static information about the filesystems (stores configuration info for mount, including ones at boot)

Probably any Linux distro has such tools at low levels. Packages and high-level (e.g. GUI) assist may vary.

Lots of research before I try any of these suggestions. Many thanks…RDK