First backup did not start automatically with Windows service running

I’m just starting out and installed and set up a small backup job. I configured the Windows Duplicati service, which is running. The job didn’t start overnight as expected because the computer hibernated, but also did not start until I opened the web console this morning (as opposed to when the computer came out of hibernation). I can’t find any errors in the Duplicati or service logs. Any idea why this did not start?

Log entry is generated at the end of the backup, the backup didn’t end so no log entry. Duplicati must have triggered the backup in time so the scheduler will wait for the next trigger.

Could you share some system specs which version of os & duplicati are you running…

Sure. I turned off hibernation of my computer last night and again it did not start at 1:00am as scheduled or when I signed on. It did run as soon as I opened the web console again.

My computer is running 64-bit Windows 7 Professional service pack 1.

The version of Duplicati is Duplicati -

Running the Windows service as Local System:

Have met .NET requirements:

What other information would be helpful?

— Approaching forensic toxicology testing from every angle!

Just to add to the information, I’m running on Windows 10 also as a service, and I sleep my machine each day and the next time it wakes it has no issues to start a missed backup.

I’m running the latest canary build but I’m sure it’s been the same with every 2.0.4x build I have tried.

Are you also running Duplicati Tray Icon? The .msi installer likes to install and start it unless told otherwise. Getting it to play nicely with Duplicati service install is a bit of work, but it’s sometimes nice to have there…

Prevent open browser when backup runs is the main reason I ask. There was some sort of odd interaction between Duplicati and the browser (I’d say the same for this post). So browsing to Duplicati starts backup?

–log-file and –log-file-log-level=Information or higher, added to a service reinstall, will make server log to file. Profiling is as noisy as you can make it. Best chance of seeing what happens, but creates a lot of output…

Make sure you are accessing the web UI of Duplicati running as a service.

While you are on the Wui stop the service in services.msc and you should see some error in the browser.

The duplicati tray icon should not be running in your taskbar notification.

Enable remote login in duplicati settings, restart the service and try accessing 0.0.0:8200 from a neighbour pc in the same lan network. It should work.

Logout all users from windows 7 or just restart the computer without login in and try accessing the Wui from another computer.

If it works you have setup to run as service correctly. You can disable remote Wui access if you wish.

How do I access the web UI of Duplicati running as a service?

— Approaching forensic toxicology testing from every angle!

To install the service run cmd as admin

cd to the Duplicati 2 directory run Duplicati.WindowsService.exe install

Go to services.msc

start Duplicati service

Login from the browser enable remote ui

Restart the service

From another computer in the same network like replace the IP with your PC’s IP on which duplicati is installed.

I’ve got this working now. Thanks for pointing me to the right way to access the web ui.

— Approaching forensic toxicology testing from every angle!