# Fedora 40, duplicati 2.1.0.103\_canary\_2024-12-21, selinux alerts

**URL:** https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844
**Category:** Support
**Created:** [January 5, 2025, 1:45am UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844 "2025-01-05T01:45:51Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![jberry02](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/f19dbf/32.png) [@jberry02](https://forum.duplicati.com/u/jberry02)
#### Post date: [January 5, 2025, 1:45am UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/1 "2025-01-05T01:45:51Z")

</div>

I just upgraded a Fedora 40 system to duplicati 2.1.0.103\_canary\_2024-12-21, and I’m getting a lot of selinux alerts. A test backup appears to be progressing nonetheless.

Did I miss an upgrade step? What can I do to quiet these alerts? The setroubleshooter steps don’t seem to be helping…

---

<div class="post-metadata">

### Author: ![jberry02](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/f19dbf/32.png) [@jberry02](https://forum.duplicati.com/u/jberry02)
#### Post date: [January 5, 2025, 2:07am UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/2 "2025-01-05T02:07:38Z")

</div>

Follow-up…

Backup reported 68610 Warnings. The ones it shows (it doesn’t show all 68610) all appear to be of the form:

2025-01-04 20:33:40 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileEnumerationProcess-FileAccessError]: Error reported while accessing file: FILE  
FileLoadException: Unable to get symlink for “FILE”, error: EACCES (13)

Where “FILE” is a different file for each warning (but the same file within a single warning).

---

<div class="post-metadata">

### Author: ![ts678](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/t/8491ac/32.png) [@ts678](https://forum.duplicati.com/u/ts678)
#### Post date: [January 5, 2025, 2:17pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/3 "2025-01-05T14:17:01Z")

</div>

> <https://github.com/duplicati/duplicati/issues/5720>
>
> \- \[x\] I have searched open and closed issues for duplicates.
> \- \[x\] I have searc…hed the \[forum\](https://forum.duplicati.com) for related topics.
> 
> \----------------------------------------
> 
> \## Environment info
> 
> 
> \- \*\*Duplicati version\*\*: 2.1.0.1\_experimental\_2024-11-25
> \- \*\*Operating system\*\*: RockyLinux 9
> \- \*\*Backend\*\*: (not related)
> 
> \## Description
> 
> Any attempt to make connection to back-end fails with permission denied (SELinux error) regarding access to \`name\_connect\` on a TCP socket.
> 
> \## Steps to reproduce
> 
> Install latest duplicati version with rpm -i \`version.rpm\`
> 
> 
> 
> \- \*\*Actual result\*\*:
> Every attempt of connection is blocked by SELinux
> \- \*\*Expected result\*\*:
> No SELinux errors
> 
> \## Screenshots
> 
> 
> 
> \## Debug log
> \`----
> time-\>Sat Nov 30 18:18:44 2024
> type=PROCTITLE msg=audit(1732987124.510:106974): proctitle=2F7573722F62696E2F6475706C69636174692D736572766572002D2D776562736572766963652D696E746572666163653D6C6F6F706261636B
> type=SYSCALL msg=audit(1732987124.510:106974): arch=c000003e syscall=42 success=no exit=-13 a0=1c3 a1=7f5ed4f2ee08 a2=1c a3=7f5e22ffc538 items=0 ppid=1 pid=(..) auid=(..) uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=(..) exe="/usr/lib/duplicati/duplicati-server" subj=system\_u:system\_r:init\_t:s0 key=(null)
> type=AVC msg=audit(1732987124.510:106974): avc: denied { name\_connect } for pid=(..)comm=(..) dest=443 scontext=system\_u:system\_r:init\_t:s0 tcontext=system\_u:object\_r:http\_port\_t:s0 tclass=tcp\_socket permissive=0\`
> 
> \## Solution
> Currently after installing all binary executables are placed in \`/usr/lib/duplicati/\`. The problem with this is that it will run in the \`lib\_t\` SELinux context type, rather than the intended \`bin\_t\` one.
> 
> \*\*Executables should be placed in /usr/bin directory with bin\_t context\*\*
> 
> Currently \_temporary fix\_ is just running \`chcon -t bin\_t /usr/lib/duplicati/duplicati-server\` to set proper context on executable.

Discusses how new location of executables might impact SELinux, plus maybe a workaround.

Discussion might benefit from more SELinux expertise. If you have it, please post somewhere.

---

<div class="post-metadata">

### Author: ![jberry02](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/f19dbf/32.png) [@jberry02](https://forum.duplicati.com/u/jberry02)
#### Post date: [January 5, 2025, 3:14pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/4 "2025-01-05T15:14:29Z")

</div>

I tried this workaround from the linked thread [Issues · duplicati/duplicati · GitHub](https://github.com/duplicati/duplicati/issues/5720:)

```plaintext
semanage fcontext -a -t bin_t '/usr/lib/duplicati/duplicati'
semanage fcontext -a -t bin_t '/usr/lib/duplicati/duplicati-*'
restorecon -r /usr/lib/duplicati/

```

So far, it doesn’t appear to have made any difference.

Digging through the thread and linked data I also see where another user updated SElinux policies - I will research those and see if they help in my case.

---

<div class="post-metadata">

### Author: ![jberry02](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/f19dbf/32.png) [@jberry02](https://forum.duplicati.com/u/jberry02)
#### Post date: [January 5, 2025, 6:43pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/5 "2025-01-05T18:43:33Z")

</div>

There is a problem with the “semanage” commands I quoted - the wildcard does not work. Here is a corrected version

```plaintext
semanage fcontext -a -t bin_t '/usr/lib/duplicati/duplicati'
for f in /usr/lib/duplicati/duplicati-*
do
  semanage fcontext -a -t bin_t ${f}
done
restorecon -r /usr/lib/duplicati/

```

Using this corrected version appears to have resolved my SElinux issues, with the caveat that I have also added various SElinux policies as well, so at the moment it isn’t clear if the above commands are sufficient by themselves, or if the policies were also needed. I am going to research how to “undo” the SElinux policies and will report back with what I find.

---

<div class="post-metadata">

### Author: ![jberry02](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/f19dbf/32.png) [@jberry02](https://forum.duplicati.com/u/jberry02)
#### Post date: [January 5, 2025, 7:13pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/6 "2025-01-05T19:13:56Z")

</div>

Follow-up.

I was able to remove the custom SElinux policies and perform a backup with no apparent issues.

I will mark my prior post with the corrected “semanage” commands as “the solution”.

---

<div class="post-metadata">

### Author: ![illandhil](https://forum.duplicati.com/user_avatar/forum.duplicati.com/illandhil/32/10677_2.png) [@illandhil](https://forum.duplicati.com/u/illandhil)
#### Post date: [February 21, 2025, 9:53pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/7 "2025-02-21T21:53:36Z")

</div>

I just wanted to say after a fresh setup on Rocky Linux and enabling duplicati as a service I had all kinds of issues until I set the mentioned selinux permissions. This resolved my issues. Thanks for finding this.

---

<div class="post-metadata">

### Author: ![illandhil](https://forum.duplicati.com/user_avatar/forum.duplicati.com/illandhil/32/10677_2.png) [@illandhil](https://forum.duplicati.com/u/illandhil)
#### Post date: [February 21, 2025, 9:54pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/8 "2025-02-21T21:54:32Z")

</div>

In particular I was getting errors resolving to the oauth service with a permissions error and it suggesting me to generate a new auth id, which wasn’t the issue. Just for anyone else the runs into a similar issue.

---

<div class="post-metadata">

### Author: ![JoeWells](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/e5b9ba/32.png) [@JoeWells](https://forum.duplicati.com/u/JoeWells)
#### Post date: [January 18, 2026, 6:08pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/9 "2026-01-18T18:08:39Z")

</div>

I just ran into this after upgrading to openSUSE Leap 16. Not only did it fail to connect to my Backblaze B2 destination (helpfully providing an error: Permission denied ([api.backblazeb2.com:443](http://api.backblazeb2.com:443)) ), it failed even to connect to [updates.duplicati.com](http://updates.duplicati.com) to check for updates.

The semanage commands listed at [Package options | Duplicati](https://docs.duplicati.com/installation-details/package-options) didn’t work for me either, but the for-loop version provided by jberry02 did.

---

<div class="post-metadata">

### Author: ![Tama](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/t/cdc98d/32.png) [@Tama](https://forum.duplicati.com/u/Tama)
#### Post date: [February 21, 2026, 12:34pm UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/10 "2026-02-21T12:34:00Z")

</div>

Fedora 43 here, sorry to necro this, but given the instructions [here](https://docs.duplicati.com/installation-details/package-options) are wrong, I wanted to suggest the command that worked for me with a single rule:

`semanage fcontext -a -t bin_t '/usr/lib/duplicati/duplicati(.*)?'`  
`restorecon -r /usr/lib/duplicati`

Would be good if the duplicati team updates that page.

---

<div class="post-metadata">

### Author: ![kenkendk](https://forum.duplicati.com/user_avatar/forum.duplicati.com/kenkendk/32/5305_2.png) [@kenkendk](https://forum.duplicati.com/u/kenkendk)
#### Post date: [February 23, 2026, 10:22am UTC](https://forum.duplicati.com/t/fedora-40-duplicati-2-1-0-103-canary-2024-12-21-selinux-alerts/19844/11 "2026-02-23T10:22:00Z")

</div>

Hi @Tama, welcome to the forum 👋

> [@Tama](#):
>
> `semanage fcontext -a -t bin_t '/usr/lib/duplicati/duplicati(.*)?'`  
> `restorecon -r /usr/lib/duplicati`
> 
> Would be good if the duplicati team updates that page.

Thanks for the fixed command. I have updated the docs now.
