Failure to restore

Updated to Mono and updated to the latest canary build, but still showing “Internal server error” when trying to restore.

I have used the command line to create a backup locally, and it restored okay.

But cannot restore using the browser… (creating backups to OneDrive and Dropbox works fine).

Can you tell me how you are doing the restore in the UI?

There are at least three methods: Restore from the Backup Job defined in the UI, Direct Restore from Backup files, or Restore from Configuration. I recommend the first option, assuming that’s how you are normally doing backups. (I see that you reference command line but am not sure if that is normally how you do backups…)

So I have tried the first two methods. When I restore using the backup job defined in the UI it errors straight away "Internal server error”.
From the restore option, I select the backup and then it errors.

I have just tried using Backblaze B2. Backed up fine but errored just trying to select restore.

However I have restored the Backblaze data using the command line so Duplicati is able to work.

So at the minute I’m backing up with the gui and restoring on the command line.

Can you elaborate on “errors straight away”? Do you mean once you initiate the restore job, or do you get that error even before you are allowed to choose what to restore?


The error appears as soon as I click Restore files…
before I choose what to restore.

Can you take a screen shot of the actual error?

Ok thanks - can you try this: open two browser tabs to the Duplicati Web UI. On the first tab navigate to About -> Show Log -> Live -> and set the dropdown to Verbose.

Go to the second tab and try to do the Restore files so you get the error.

Go back to the first tab and copy/paste the log entries here.


Yeah it doesn’t show any new messages.

The last messages are when the backups complete. (21 May 2020 20:23: The operation Backup has completed)

I’ve tried verbose and profiling.

The verbose live log is working because all of the backup jobs that were scheduled overnight are shown in the log (I left the browser window open overnight).

But I tried restoring just now and nothing shows in the log.

Hello, i have the same problem.
Duplicati make a backup on SFTP server (the backup is OK).
When i want to restore, i have the error “Internal Server Error”. Impossible to choose a file to restore.

There is no message in log (verbose mode).

OS version : ubuntu 16.04
Mono : test with 4.2.1, and
Duplicati :

Very strange… what OS are you using on your VPS?

Hi @Nicolas, welcome to the forum.

I’m curious if the OP has the same OS as you. As far as mono versions go, you definitely want to be using 5.x or greater - don’t go back to the 4.2.1 version.

How are you running Duplicati? As a service (running as root), or as a user?

Hey - I’m also using Ubuntu (20.04) and Mono

Running Duplicati (Canary) as as service.

Well, did a quick test and wasn’t able to reproduce a problem with the restore function.

OS: Ubuntu 20.04

Hello, i’m using Duplicati as a service as root

Ok, i have found the problem.

In fact, this came from apache2 with mod_proxy.
Before, the apache config file contains :

ProxyPass / http://localhost:8200/
ProxyPassReverse / http://localhost:8200/

I had this line

AllowEncodedSlashes On

And now it works :slight_smile:

See this post : Reverse Proxy on NGINX


That’s great news.

It has also resolved the restore error for me :smiley:

However, with the old backups and with new backups, I’m getting “Restore completed without errors but no files were restored”.

This is from the log (this particular one is just restoring a text file to test):

“RestoredFiles”: 0,
“SizeOfRestoredFiles”: 0,
“RestoredFolders”: 0,
“RestoredSymlinks”: 0,
“PatchedFiles”: 0,
“DeletedFiles”: 0,
“DeletedFolders”: 0,
“DeletedSymlinks”: 0,
“MainOperation”: “Restore”,
“RecreateDatabaseResults”: null,
“ParsedResult”: “Warning”,
“Version”: “ (”,
“EndTime”: “2020-05-25T20:47:54.399443Z”,
“BeginTime”: “2020-05-25T20:47:54.308193Z”,
“Duration”: “00:00:00.0912500”,
“MessagesActualLength”: 7,
“WarningsActualLength”: 1,
“ErrorsActualLength”: 0,
“Messages”: [
“2020-05-25 20:47:54 +00 - [Information-Duplicati.Library.Main.Controller-StartingOperation]: The operation Restore has started”,
“2020-05-25 20:47:54 +00 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: List - Started: ()”,
“2020-05-25 20:47:54 +00 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: List - Completed: (3 bytes)”,
“2020-05-25 20:47:54 +00 - [Information-Duplicati.Library.Main.Database.LocalRestoreDatabase-SearchingBackup]: Searching backup 0 (5/25/2020 8:47:25 PM) …”,
“2020-05-25 20:47:54 +00 - [Information-Duplicati.Library.Main.Operation.RestoreHandler-RemoteFileCount]: 1 remote files are required to restore”,
“2020-05-25 20:47:54 +00 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Get - Started: (1.01 KB)”,
“2020-05-25 20:47:54 +00 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Get - Completed: (1.01 KB)”
“Warnings”: [
“2020-05-25 20:47:54 +00 - [Warning-Duplicati.Library.Main.Operation.RestoreHandler-NoFilesRestored]: Restore completed without errors but no files were restored”
“Errors”: ,
“BackendStatistics”: {
“RemoteCalls”: 2,
“BytesUploaded”: 0,
“BytesDownloaded”: 1037,
“FilesUploaded”: 0,
“FilesDownloaded”: 1,
“FilesDeleted”: 0,
“FoldersCreated”: 0,
“RetryAttempts”: 0,
“UnknownFileSize”: 0,
“UnknownFileCount”: 0,
“KnownFileCount”: 3,
“KnownFileSize”: 2903,
“LastBackupDate”: “2020-05-25T20:47:25+00:00”,
“BackupListCount”: 1,
“TotalQuotaSpace”: 33764929536,
“FreeQuotaSpace”: 14215327744,
“AssignedQuotaSpace”: -1,
“ReportedQuotaError”: false,
“ReportedQuotaWarning”: false,
“MainOperation”: “Restore”,
“ParsedResult”: “Success”,
“Version”: “ (”,
“EndTime”: “0001-01-01T00:00:00”,
“BeginTime”: “2020-05-25T20:47:54.308196Z”,
“Duration”: “00:00:00”,
“MessagesActualLength”: 0,
“WarningsActualLength”: 0,
“ErrorsActualLength”: 0,
“Messages”: null,
“Warnings”: null,
“Errors”: null

Any ideas?

Thank you.

This is the kind of message that can happen when no restore is necessary to get the desired file.
Are you restoring to the original location, with the file already all set? If so, try a different location.
Duplicati tries to ensure you get what you want, in an efficient manner, including using local data.
This can get in the way of reliable restore testing, but there’s a –no-local-blocks option that helps.

1 Like

Oh wow. Yes that is what it was. Thank you! :smiley: