Failed to process path on PST file

Hello everyone,

I’ve been using the Duplicati software for some time and I’m getting the below error when trying to backup a PST file located on shared folder.

The Duplicati is hosted on a WinSRV2012R2 and is running as global administrator and the version is 2.0.51 and the snapshot policy is set to required.
The shared folder is accessible from windows explorer without any issue.

It seems that something is missing from my configuration right?

thanks in advance

Hello and welcome!

The PST file is probably open and locked by a user. Duplicati cannot back up open files without using snapshots, and shapshots are only an option for local data. Looks like you are backing up remote data.

Hi drwtsn32,

Thanks for the reply,
Indeed the pst file is located on another PC on the domain. The Duplicati instance is installed on the DC and looks into a shared folder where the PST is stored.
Putting down to simple words, I have to install the Duplicati on the same machine as the PST is, and enable the snapshot function as well. Am I right?


Yes, if you run Duplicati on the machine that hosts the data, you’ll be able to use VSS to back up open files. You will have to run Duplicati with elevated rights. One method of accomplishing this is to run it as a service. If you want to do it this way, uncheck the “launch at startup” option when installing Duplicati and instead follow the instructions here for installing as a service:

Hi drwtsn32,

I’ve tried as per your instructions and still I’m getting the same error.
I’ve set also the snapshot policy to all possible options without a result. Normally should be set to required while the VSS service is enabled. Am I ok on that?

I’m able to backup the pst while the Outlook is not running.

thanks a lot

Setting it to Required should fail the job if Duplicati fails to create a snapshot. With it set to Required does the job still complete successfully?

Also confirm that you are using local paths (not UNC paths) on the source data screen of your backup configuration.

Good afternoon,

Thanks for your replies,
I’ve got some updates,

The process is going on when I am logged in as administrator but when I return to local user (domain user) it fails, producing an error “Attempted to perform an unauthorized operation”
It seems that even if I configured it to run as a service, it still misses something or I have not done something properly. Just for information, I’m running the process from the GUI for testing until I get to a good result and then I will schedule the repeated task. I don’t know of that affects…


Please make sure you are connecting to the right instance of Duplicati. By default a tray icon tries to start at logon, and that will start a new instance of the Duplicati engine.

Exit the tray icon and delete them out of the startup folder(s) for any user that logs in to this server. Then restart the service. You should be able to connect to the service instance of Duplicati at http://localhost:8200 at that point. The backups should work regardless of who is logged in (or even when no one is logged in).

Good afternoon drwtsn32

Issue has been resolved! I’m applying the solution to all affected PC’s. Many thanks for the assistance.


1 Like