"Failed to process path" messages? Are my files being backed-up or being skipped?

This is my first time trying out Duplicati and I’ve set it up on an ARM device running Debian 8 following the headless guide on the wiki.

I am doing my first backup to OneDrive from an external USB hard disk and a several hours in to the process, I start getting repeated “Failed to process path” messages.

The backup keeps on running though - does that mean these files are being skipped? There are still several hundred GB to go, so I’m wondering if there will be a point in letting it continue if it ends up missing thousands of my files in the backup.

I tried stopping the backup and then starting it up again, but the problem persists.

The detailed exception information accompanying these messages is:

{
    "ClassName":"System.NullReferenceException",
    "Message":"Object reference not set to an instance of an object.",
    "Data":null,
    "InnerException":null,
    "HelpURL":null,
    "StackTraceString":"  at Duplicati.Library.Main.Volumes.BlockVolumeWriter.AddBlock (System.String hash,
        System.Byte[] data,
        System.Int32 offset,
        System.Int32 size,
        Duplicati.Library.Interface.CompressionHint hint) [0x00032] in <118ad25945a24a3991f7b65e7a45ea1e>:0 \n  at Duplicati.Library.Main.Operation.BackupHandler.AddBlockToOutput (Duplicati.Library.Main.BackendManager backend,
        System.String key,
        System.Byte[] data,
        System.Int32 offset,
        System.Int32 len,
        Duplicati.Library.Interface.CompressionHint hint,
        System.Boolean isBlocklistData) [0x000b1] in <118ad25945a24a3991f7b65e7a45ea1e>:0 \n  at Duplicati.Library.Main.Operation.BackupHandler.ProcessStream (System.IO.Stream stream,
        Duplicati.Library.Interface.CompressionHint hint,
        Duplicati.Library.Main.BackendManager backend,
        Duplicati.Library.Utility.FileBackedStringList blocklisthashes,
        Duplicati.Library.Utility.FileBackedStringList hashcollector,
        System.Boolean skipfilehash) [0x000d8] in <118ad25945a24a3991f7b65e7a45ea1e>:0 \n  at Duplicati.Library.Main.Operation.BackupHandler.HandleFilesystemEntry (Duplicati.Library.Snapshots.ISnapshotService snapshot,
        Duplicati.Library.Main.BackendManager backend,
        System.String path,
        System.IO.FileAttributes attributes) [0x00471] in <118ad25945a24a3991f7b65e7a45ea1e>:0 ",
    "RemoteStackTraceString":null,
    "RemoteStackIndex":0,
    "ExceptionMethod":null,
    "HResult":-2147467261,
    "Source":"Duplicati.Library.Main"
}

Ok, so I did let everything finished and the backup does not show as completing successfully.

I tried a few more times and eventually what I discovered was that I had one file being backed-up that was larger than my temporary directory (tmpfs; aka a RAM disk). When it hit that file, an exception about disk space was logged, and then every file after that (even though they were small enough to fit in my tmp directory), started erroring out on NullReferenceExceptions.

I reconfigured Duplicati to use a temp directory on an external hard disk with enough space, and the backup is now moving along with no errors yet. Hopefully it will be ok this time!

1 Like

Welcome to the forum @acee, and thanks for sharing your detective work on that!

Hopefully I’ll have some time to test your failure scenario of running out of space on temp the temp drive causing all following files to fail with NullReferenceException errors.

@kenkendk, when this happens do you think one of these options is better than another?

  • the job should be aborted (CON: job will ALWAYS abort when it hits the space issue)
  • the job should continue (CON: the specific file(s) will not be backed up - does that end up causing a failure report?)