Failed to Find Backup: Missing XSRF Token: Please reload the Page

I have setup Duplicati to save backups to my Dropbox Account. I have 2Tb and plenty of that is free. Everything seemed to be going along swimmingly until 24/12/2019 (I did not notice until today, I’ve been away and busy with other things). So essentially no backups since Christmas Eve. Not critical at this stage, because the backup is only the Test server, we are not in production yet.

Regardless, I had to lookup and see what an XSRF token was. I’m still not sure, but I know it is essential to stop other apps getting into the backup process.

I find the error message provides no useful information. Firstly the error WRT error reading JObject, that provides me with absolutely no useful information other than there was an error (having said that it may be useful for technical support). To me it’s essentially a Microsoft error, 100% accurate and totally useless.

The next error is the one regarding Missing XSRF Token. Again 100% accurate and totally useless since I do not understand where the XSRF token might be - that’s a bit of a deal breaker to start with.

I have absolutely no idea what page needs to be reloaded and how to reload that page. Because the word token was used, I generated a new Dropbox auth token? checked that Dropbox was accessible and started a backup to make sure the backup actually works. I do not know if this is what’s required, but it seemed to work. Further confusing XSRF is synonymous with CSRF (which 99% of web searches and documentation returns). That’s also initially very confusing.

So my assumption is that the Dropbox Auth Token is the CSRF token which is the XSRF token the error message was referring to. As I look at the files from the backup I have just started, there are new files starting some 32 minutes ago so again, I assume the backup is working. And it did indeed work:

Is there somewhere that I can go that translates errors, if not might I suggest that this would be very useful. For example:

Problem: If you get a Failed to find backup: Missing XSRF Token and are backing up to a proprietary cloud system such as Dropbox, the Auth Token is no longer recognised, we do not know why this has happened

WorkAround: Regenerate the Auth Token, confirm it can connect to the cloud service, start a backup and confirm backup files are being generated’

When Duplicati works, it’s great especially backing up to a proprietary cloud system, that’s just the bees knees. I have recovered from such a backup (it took a long time, but was indeed a life saver (sic)). When it kinda arbitrarily fails, it can be confronting and confusing. Just an observation.

So my question (after all that): What Page is the error message talking about and how do I reload it?

Thanks,
Kevin

And my nightly backup, I get this warning:

Warnings: [
2020-01-06 01:00:00 +11 - [Warning-Duplicati.Library.Modules.Builtin.CheckMonoSSL-MissingCerts]: No certificates found, you can install some with one of these commands:
cert-sync /etc/ssl/certs/ca-certificates.crt #for Debian based systems
cert-sync /etc/pki/tls/certs/ca-bundle.crt #for RedHat derivatives
curl -O https://curl.haxx.se/ca/cacert.pem; cert-sync --user cacert.pem; rm cacert.pem #for MacOS
Read more: http://www.mono-project.com/docs/about-mono/releases/3.12.0/#cert-sync
]

Of course, I have no idea what this means. Now the backup took only 18 minutes. That’s probably not unreasonable, but I just want to make sure all was OK, ie. the warning wasn’t warning me because of a cert issue the backup really didn’t happen. If required I can supply the rest of the log file, it essentially has the same certificate warnings.

Note this is for Linux MINT (I assume UBUNTU):

After a fair bit of disappearing down rabbit holes, I finally got cert-sync to install, because if I executed the lines that was advised by Duplicati log file it said cert-sync was NOT found. Again, I did have mono installed because I tried to install it and was advised installed (this is way past my knowledge base).

I finally found that I needed to install the ca-certificates-mono package:

sudo apt-get install ca-certificates-mono

This then installed cert-sync and reacted the missing certificate. I did a cert- sync and was advised the certificates were there.

sudo cert-sync /etc/ssl/certs/ca-certificates.crt

I further found that the warnings were not fatal, the backup had succeeded. So yes, somewhat ignorant noob, but if I can now get those warnings to disappear I might be able to put this issue to rest.