Failed to connect: No such file


#11

If you mean “me” as “the user”, then I can certainly log into the NAS from a terminal window using the same credentials and create files, list them and so forth. So the question is why can’t Duplicati do it?

At this point, unfortunately I’m going to have to give up on Duplicati and find something else. Crashplan disappears for me in a month so I’m running out of time to get an alternative backup solution running


#12

I don’t use Synology as a destination, but I do use Synology as a destination to sync my pc with my NAS (via syncthing). With that application, I also had some issues with authorizations, that I managed to work out, don’t know how.

Could you try to specifiy the alternate path:

/volume1/homes/username

That is a link to the

/var/services/home/username

Just a guess… Duplicati is too good to give up…


#13

That was actually the first thing I tried after installing Duplicati - I realized they were symbolic links. However, when I do that, I just get a message that the folder /volume1/homes/username (obviously replaced with my username) doesn’t exist.
Clearly Duplicati can’t see the file system but how do I fix it?


#14

are you connecting with an admin user?


#15

I’ve tried with both my personal userid (which is in the admin group) and the root userid (admin)

By the way, if there is any way to get some support, perhaps a remote desktop sharing session, I’m happy to pay a fee. Is there someone to contact for such things? I would love to use Duplicati but running out of time to get backup system running before Crashplan expires.


#16

Tried it myself here. I am getting the same error here (beta release).

Duplicati.Library.Interface.FolderMissingException: Unable to set folder to /var/services/homes/XXXX/dup_test/, error message: No such file ---> Renci.SshNet.Common.SftpPathNotFoundException: No such file at Renci.SshNet.Sftp.SftpSession.RequestOpenDir(String path, Boolean nullOnError) at Renci.SshNet.Sftp.SftpSession.ChangeDirectory(String path) at Duplicati.Library.Backend.SSHv2.ChangeDirectory(String path) --- End of inner exception stack trace --- at Duplicati.Library.Main.BackendManager.List() at Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, String protectedfile) at Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, String protectedfile) at Duplicati.Library.Main.Operation.BackupHandler.PreBackupVerify(BackendManager backend, String protectedfile) at Duplicati.Library.Main.Operation.BackupHandler.Run(String[] sources, IFilter filter) at Duplicati.Library.Main.Controller.<>c__DisplayClass16_0.<Backup>b__0(BackupResults result) at Duplicati.Library.Main.Controller.RunAction[T](T result, String[]& paths, IFilter& filter, Action`1 method) at Duplicati.Library.Main.Controller.Backup(String[] inputsources, IFilter filter) at Duplicati.Server.Runner.Run(IRunnerData data, Boolean fromQueue)

Maybe try to install the webdav server from synology and use webdav access? Untill someone figured out what goes wrong here…


#17

Yeah, that’s an option — the thing is, I want to use this stuff remotely and I really only wanted to allow SSH connections (on a non-standard port!)

But I’m glad to know I’m not the only one running into this problem. Who reports such bugs?


#18

I guess you could log it to github.

Webdav tunneled over ssh? I run on non standard ssh port as well. Did you try on standard ssh port?maybe issue is there?

Did you check with other clients (winscp etc) if you can reach it over sftp? To rule out synology itself.


#19

I"m still using the standard ports — once I had it up and running I will change to non standard port.

And yes, I can reach the Synology over SSH from a terminal window on any other computer in my network (Mac, Linux and even (oh god!) winscp on Windows. Once there I can create files and folders, list them, etc without any issue.

Also, I installed webdav on the synology, enabled both http and https ports but when I try to test from duplicati I get an error “Failed to connect: The remote server returned an error: (405) Method Not Allowed”

However, WebDav is clearly working fine because I can open my home folder from a Mac (same Mac that’s running Duplicati by the way) using webdav credentials and port with no problem.

It seems to me that Duplicati is just not ready for prime time. These are really basic issues (just connecting) and so it just shouldn’t be this hard, particularly since I can connect to the same services from other apps with no issue


#20

I agree, it really shouldn’t.

The WebDAV “(405) Method Not Allowed” error might be the same one mentioned here:

That being said, it sounds like you’ve tried a lot of different methods (thanks!) but just keep running into issues. I know other Synology users are using Duplicati without such issues (at least not that they’re reporting) so I’m stuck assuming your environment or implementation is set up in a way that Duplicati doesn’t handle well.

It would be great if you had the time to help us iron out exactly what the issue is, but without us being able to guarantee results within a particular time frame I certainly understand about the time pressure of dealing with CrashPlan’s announcement.

If you end up finding another tool that works for you please let us know what it is (and what didn’t work for you) in case other Synology users trying out Duplicati run into issues like yours. We’d much rather have people backing up with another tool than not backing up at all!

And keep us in mind once your new tool is in place - Duplicati is actively being developed so at some point we’ll hopefully figure out what’s been causing you so many issues and get it resolved. :slight_smile:


#21

found it!!

You should provide the path as follows:
/home/duplicati_path

Not using /volume1 or /var or…

Discovered that by connecting via ftp, and the url did not have the /volume/ or /var path in it.

Could you please confirm this works for you as well?

Wim


Fatal error during backup to Synology via UNC share
#22

Great! Though I can’t confirm it (no Synology box, saddly) but perhaps @David_Jameson hasn’t uninstalled Duplicati yet and can give it a try…


#23

Bloody hell — that worked! You know, when I was experimenting with WebDav and opened a Finder folder to the Synology, I noticed there was a single “home” folder there as well as the “homes/user” folder. I actually went looking for that ‘home’ folder but couldn’t find it anywhere.

So ok, did that, and I have started a backup of one hard drive. Keeping my fingers crossed — and THANKS so much for figuring it out.

Of course from a technical point of view, I’m curious as to WHY this worked and why the previous mechanisms did NOT work?


#24

you are welcome & good luck!!

my 2 cents: synology exposes the home folder differently than a normal Linux-based OS…

Probably google outside duplicati can help us further here… As I don’t think this is duplicati related…


#25

Wow! I had no idea you needed to do that. Awesome that you figured it out.

Now that I know this, I think you could have found out by using FileZilla or CyberDuck to connect, as it would show the paths.

I do recall that Synology monkey patches sshd with some login integration. It sounds like they patched sftp as well such that it does not expose the /volume stuff, which is really confusing as they have not (and could not) patch normal ssh access the same way.


#26

it was with an ftp client (firefox :slight_smile: ) that I noticed the path difference…


#27

So is your hard drive backed up now?

If so, please consider clicking the checkmark in Wim_Jansen’s post so other users know that’s the trick that slaved the issue. :slight_smile:


#28

God no, it still has 361,000 files (522GB) to backup — I’m assuming it’s going to be 3 or 4 more days given that we started with 750,000 files or so. But you’re right - the suggestion worked so I’ll mark that.


#29

I don’t have CyberDuck any more but I just tried to connect using Forklift and it displayed both “home” and “homes” and if I ask for the url of the former I just get

sftp://ipaddress/home

so yeah, that would have been a clue.


#30

I’m having the same issue - but with my own NAS which runs a mix of Debian testing and OpenMediaVault. I’ve set up a backup using borgbackup, which is working fine, but I wanted to try Duplicati just for fun (well actually it supports Amazon Drive out of the box, which is what I’m looking for).

I have a ‘backup’ user on my NAS who has a home directory residing on /export/NAS/Backup - borgbackup is just putting its files in a directory relative to the home directory of that user.

If I try doing the same thing with Duplicati I get the ‘Failed to connect: No such file’ error. Just to be clear, I’m using SSH file transfer (SFTP).

I was trying with ‘duplicati/pcname’ or ‘/duplicati/pcname’ or ‘~/duplicati/pcname’ or ‘./duplicati/pcname’

I also tried connecting with FileZilla using SFTP which works fine, I can access the folder, create stuff, delete stuff. Just like borgbackup does as well.

I also created the directory and tried again with duplicati - to no avail. If I leave the directory empty it says okay but ends up with a permission error. Troubleshooting is hard because I have no idea where Duplicati is trying to go.

Solution: This still seems like a bug in Duplicati:
Put

/home/../export/NAS/Backup/duplicati/pcname

into the folder.

I find that rather strange and completely counter intuitive compared to how every other tool at my disposal handles this.