Experience with scaleway?

Hi all,
Anyone with experience using scaleway? I’m having issues getting files restored from their glacier storage, and their support team is only sending messages that they do not have any updates…

I was wondering if anyone is using it, and has similar issues in the past?

Duplicati doesn’t support Glacier/cold storage.
You have to change the files’ Storage Class from Glacier to Standard, before you can get the files.

I know. Therefore, I work via a script that restores from glacier before downloading. Worked great. But stopped working some time ago, as a lot of files fail to restore…

I’m afraid there is something wrong with their infrastructure…


Did you allow for enough time for SW to move the files to Standard? This undefined time could be an issue.

BTW I have just started testing Scaleway yesterday - only with Standard storage class - and haven’t had any problems.

Yes, it’s going on for 4 days already. Still in glacier…

As soon as the data is restored (if ever) I move away from scaleway. Customer support sucks. No updates except saying they have no updates.

I now have 360 files failing to restore from glacier, from 2 backup sets (not including the biggest ones yet). Restore started 12h ago, so should be done. I’m ok to give it a day or so, but am afraid status will not change overnight…

No, but I’ll try helping.

Is it basically still this? That’s a one-by-one restore using AWS CLI, with lots of logging (showing what)?

Did you try asking from the Scaleway Console? It might also allow batch restore, but need file guessing.
Alternatively it looks like there might be a box in their web UI that will let you select all of the files at once.
I’m not sure how much overkill that would be. Might depend on how recently a compact was able to run.

1 Like

Trying to eliminate Duplicati from the error-chain. Where does it fail:

  1. Can you move the files from Glacier to Standard in Scaleways web-UI?
  2. Can you download the “hot” files manually from web-UI?
  3. Does Duplicati complain when restoring from the downloaded files?


(I’m currently evaluating Scaleway as a secondary destination, so I want to dig into this potential issue).

Sorry for the late reply. Files are still getting restored from Glacier but at this rate its going to take months…

It’s not duplicati related at all. Purely scaleway.

If the files are restored, downloading is OK. So it’s likely related to their Glacier solution and extremely slow restoring…

Object Storage - C14 Cold Storage Class does give them up to 6 hours.
Have you tried putting multiple requests in their queue at the same time?
If their delay is per-request, lots of files will mean lots of individual delays.

I wonder if their support could tell you whether batching will be any faster.
If you still want to move away would you be taking all of the existing files?

Their support is terrible. I haven’t received a decent response to my questions since 2 weeks. I have left the support team quiet now for a few days, will check for updates next week.

6 hours would be OK for me. More than OK. But over 2 weeks? Seriously? They have to manually fetch the tapes from the basement or what?

Every file I restore goes immediately to backblaze now. Started a Google cloud ubuntu instance to move the files.


Batching does not seem to be possible. Recursive restore is, but not sure that is the same as batching.

Tried individual restores and recursive. Sane result.

I wasn’t sure what I saw in the upper left corner. Does their UI even allow one to select more than one file?

Batching is just my name for not doing one-at-a-time restore-and-wait as your posted Duplicati script did.

If that’s like How to restore folders (or entire buckets) to Amazon S3 from Glacier?, then I guess you tried.

s3cmd restore --recursive s3://mybucketname/folder/

after 4 weeks, they finally were able to point me to this issue:

not a solution - but at least now I have some info about what is happening

1 Like

it seems to be working again - I can download files again, and for safety, I’m putting them in backblaze as well.

1 Like