Exclude file not working

I have filter “Exclude file” “UnityLockfile”

but anyway got error

Failed to process path: …\UnityLockfile => The process cannot access the file ‘…\UnityLockfile’ because it is being used by another process.

Can you provide an “Export -> As Command-line” output (with stuff like usernames, passwords, hashes hidden)?


Thanks! I need to double check but it looks like you have a regular expression filter in a “just plain file make” spot.

this not works:
^ this produce error ...\UnityLockfile' because it is being used by another process.

then, this:
produce this error:

but this works ok:

Unfortunately I don’t read Russian(?) but if placement is the same then I’m glad to hear "Exclude expression" is working for you!

I’m not sure why "Exclude files whose name contains" or "Exclude file" didn’t work (unless it’s a folder, not a file) but you figured it out, which is good.

You might also want to look at the --snapshot-policy parameter as it defaults to OFF…

  • “off” makes Duplicati not attempt to create a disk snapshot (and it can’t back files locked by other programs)
  • “auto” makes Duplicati attempt to create a snapshot, and fail silently if that was not allowed or supported
  • “on” will also make Duplicati attempt to create a snapshot, but will produce a warning message in the log if it fails
  • “required” will make Duplicati abort the backup if the snapshot creation fails.

Note that on windows this uses the Volume Shadow Copy Services (VSS) and requires administrative privileges. On linux this uses Logical Volume Management (LVM) and requires root privileges.

anyway duplicati is best backup program !

Thanks - glad you think so! :smiley:

Not sure exactly what goes on here, but this expression should be the working expression: *\UnityLockfile.

And I would expect the UI to generate this rule in the “exclude files with this name” option.