Excel timestamp files are not saved

every time I open an excel file the metadata or timeline that is generated in the hidden state is not saved in the backup copy. Help!


Configuracion del backup

This error only happens to me with Microsoft Excel files

Doesn’t look like you are using snapshots. Those Excel temp files are locked by the Excel process while the file is open, from what I recall. If you don’t use VSS snapshots with Duplicati, it won’t be able to back up those (or any other locked/opened file).

1 Like

@drwtsn32, because if I can make the backup copies of the temporary Microsoft Word files which are in the same location. Help!

Maybe Word doesn’t lock the temp files like Excel does.
Try enabling snapshots or just exclude temp files from backups (they don’t need to be backed up anyway).

and more specifically, try enabling them in a way that alerts you if snapshot can’t be done. The current setting of --snapshot-policy=auto doesn’t do that. It will give up silently, and then you can’t backup your locked files…

–snapshot-policy (you can set required for maximum certainty snapshots get done, but on will probably do)

Currently, at this moment I have the backup with the same files in two different computers, one with windows 10 and windows 7. The fault I have with the one that has Windows 10 the configuration is exactly the same in both computers.

Perform the same tests on both computers and only I have the one with windows 10.
What I can do ?

You already perform this procedure in the configuration and it does not work either.
Also perform the exclusion, but it did not work



To confirm, your original screenshot (portion shown above) is now obsolete? What is the setting currently?

For your filter, the translation seems to be “Exclude folder”. What’s the logic behind the content, and is that ~$[.\\x7E[^ shown? Is it your input (if so, please explain the intent) or something Duplicati came up with?

What I see looks sort of like regular expression intent, but Exclude folder aims for wildcards. This post was similar confusion, but it also points to a regular expression tester which might help if you’re trying that style (however you’d then probably want to enter it in the GUI using the “Exclude regular expression” dropdown).

Filters gives some basic explanations, but not far enough to explain how the different GUI dropdowns work. Additionally, the plus and minus syntax is somewhat specialized, but correspond to –include and –exclude which you can see (and control directly) if you try backup (for testing) using the job’s Commandline screen.

I’m not sure why your snapshot doesn’t appear to be working or complaining (unless it’s still set to on), but if that can be solved it would be a more general solution to locked files than filtering them out as they occur.

1 Like

I want to thank you @ts678 and @drwtsn32 for your support and great help.
I am looking for the reasons to implement this backup software to offer you as a service, to fulfill this objective I need to be completely sure that it works.

Today, thanks to you, I can continue without any excuse. Thank you

Unfortunately, beyond explaining things to users, and avoiding avoidable bugs, there are still cases where problems arise through not-yet-understood failures, and manual intervention and correction is necessary. Duplicati remains in beta for this reason. It’s not like people wouldn’t like it fully solid, but it just isn’t 100%. Being software (with a lot of external factors to add trouble), it won’t be perfect, but better would be better.

Hang around the forum for awhile to see how you want to present it to your service users, then support it. Having a packaged bundle including storage might at least avoid having to support all possible backends. Duplicati is super-flexible in many ways, and if you support all, your forum may look a lot like this one. :wink:

1 Like