Errors with directory access and Detected non-empty blocksets with no associated blocks!

I’ve seen a few people report this error. I got the error first with duplicati- I’ve just upgraded to duplicati- and I get the same error. The log file doesn’t show anything but it does give me a warning.

Warnings: [
    2019-07-28 22:02:16 -04 - [Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --auth-u is not supported and will be ignored

When I run repair, it gives me a yellow flag about this particular warning. But backups fail hard.
I tried a delete rebuild before and it ran for days and days and days. The UI says I have 146 GB with eight versions. Seems like it shouldn’t take that long to rebuild.

Another backup gave me the warnings:
Duplicati.Library.Main.Operation.Backup.FileEnumerationProcess-FileAccessError]: Error reported while accessing file: C:\Users\xyzzy\,

As far as I know, Duplicati is running as admin and should be able to read this directory.

This backup also gave me warnings like:

2019-07-28 22:00:59 -04 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-CheckingErrorsForIssue1400]: Checking errors, related to #1400. Unexpected result count: 0, expected 1, hash: rTLs5PzslZx/btfhBMFSYGNMCEaYIkevNX83uHgmRLI=, size: 102400, blocksetid: 403381, ix: 25, fullhash: WZCckGySbIsHjrsAIx+L5vFoGt975B8lF+XPy3J6sSA=, fullsize: 2683356,

I’m going to try repair on this one and see if it fixes the problem. This backup is only 111 GB and three versions.

Regarding the --auth-u error, please look at this post to see if it may apply in your case: ?auth-u automatically added to destination path

I do not believe you need to attempt a database repair because of the above error - it sounds more like a job configuration issue.

It may be running as a user with Administrative rights, but is it running Elevated? Task Manager Details tab may help you identify this for sure. (You may have to turn on the “Elevated” column - I don’t recall if I did that or if it is visible by default.)

I’m not familiar with this one, but there is a discussion about issue 1400 on Github:

Are you trying to back up Duplicati’s own database?
Are you using snapshots?