"Error while running..." - "Found 3 remote files that are not recorded in local storage, please run repair"

My very first try errors off. I don’t understand this error at all. And what is this “repair”. Not mentioned anywhere that I can find.

I thought it might be a command line thing, and when I went that route I got another problem (see next post).

Click on your backup (so that the options are displayed). There you find “Database …” and within that you find “Repair”.

Please note that only one backup must be writing to the destination folder. If any other backup job or any other application is storing files in the same destination folder, Duplicati will complain about this.

Thanks for your response. I found the “repair” function - it errored off:

“Error while running main [my backup name]
The database was attempted repaired, but the repair did not complete. This database may be incomplete and the repair process is not allowed to alter remote files as that could result in data loss.”

The delete function errored off too:

“Error while running main
Failed to decrypt data (invalid passphrase?): Invalid password or corrupted data”

Looking at the command line I keep seeing messages like this one:

No certificates found, you can install some with one of these commands:
cert-sync /etc/ssl/certs/ca-certificates.crt #for Debian based systems
cert-sync /etc/pki/tls/certs/ca-bundle.crt #for RedHat derivatives
Read more: Release Notes Mono 3.12.0 | Mono
Failed to send notification: System.IO.FileNotFoundException: Could not load file or assembly ‘notify-sharp, Version=, Culture=neutral, PublicKeyToken=2df29c54e245917a’ or one of its dependencies.
File name: 'notify-sharp, Version=, Culture=neutral, PublicKeyToken=2df29c54e245917a’
at Duplicati.GUI.TrayIcon.GtkRunner.NotifyUser (System.String title, System.String message, NotificationType type) <0x41de9bd0 + 0x00037> in :0

I started the duplicate server with this command:

duplicati --accept-specified-ssl-hash=66ADA7F8C7EBC4F16F1E37C6A71A6DEC36D58772

According to error messages previously output on the command line, that should have taken care of the server certificate problem. It didn’t.

i tried just deleting the entire backup configuration and starting anew. When I tried to run the backup I got this error message:

“Error while running tcmain
Found 3 remote files that are not recorded in local storage, please run repair”

Lots of things not working. I’m not sure what to try next.


UPDATE-1: In desperation, I manually deleted the directory containing the output backup files, reran the new backup configuration, with no changes, and it’s running now without complaint. Looks like progress!

UPDATE-2: My backup configuration now runs without complaint. I’ve added files and rerun it multiple times. It’s fast, and I love the output sent to the interface. I’m very pleased to have gotten to this point. I’m also delighted with the overall design of this program. I found it in the Arch wiki - Synchronization and backup programs - ArchWiki - It was not mentioned anywhere else that I looked for Linux backups, which is unfortunate given the quality of its design and function.

1 Like