Error restoring from Google Drive

Hi all, I am pretty new to Duplicati, but I’ve used it successfully in the past. Yesterday, I backed up some files from one computer to Google Drive using Duplicati. Today, when I try to restore them to a different computer, I get the following error: “No filesets found on remote target”. The “Test Connection” works, however, and I’m sure the directory is correct.

The log says:
Apr 2, 2020 8:19 AM: Request for http://localhost:8200/api/v1/backup/cee76c29-a37a-484f-8b9c-6533b775d48f/filesets gave error
Duplicati.Library.Interface.UserInformationException: No filesets found on remote target
at Duplicati.Library.Main.Operation.ListFilesHandler.Run(IEnumerable1 filterstrings, IFilter compositefilter) at Duplicati.Library.Main.Controller.RunAction[T](T result, String[]& paths, IFilter& filter, Action1 method)
at Duplicati.Library.Main.Controller.List(IEnumerable`1 filterstrings, IFilter filter)
at Duplicati.Server.Runner.Run(IRunnerData data, Boolean fromQueue)
at Duplicati.Server.WebServer.RESTMethods.Backup.ListFileSets(IBackup backup, RequestInfo info)
at Duplicati.Server.WebServer.RESTHandler.DoProcess(RequestInfo info, String method, String module, String key)

I tried giving it Google Drive Full Access instead of limited, but that didn’t help. Any ideas?



Welcome to the forum @bradnyk

Is this a Direct restore from backup files from a personal account? What OS are backup and restore?

It sounds like Duplicati is seeing an empty folder or at least one that has never finished a backup to it.

At what folders do you see at your path? There can be many. Any dlist files?

“C:\Program Files\Duplicati 2\Duplicati.CommandLine.BackendTool” list “googledrive://folder/subfolder?authid=authid”

can give you a full listing of what Duplicati sees. You can get the googledrive URL from your backup’s Export As Command-line or just build it up using the template above. Expect dlist, dblock, dindex files.

So that means you tried limited first? If not, please do. Also check for duplicate folders with same path. Google Drive allows this and it can be confusing.