Error reported while accessing file Content.IE5

Hi compatriot!

Your regular expressions included these path… “Includi espressione” means “include these path in the dataset” despite of the filed “filtri”. If you want to exclude these path to backup job edit the expressions and turn ‘+’ in ‘-’ It should work.

Hi xblitz and thank you for your reply. Perhaps it is necessary to start from the scratch; I have installed duplicati in this way:

In this server there are many users and I don’t want to specify for everyone which directory to backup, so I have created this template like in the picture below:

My goal is to backup desktop folders, documents, favorites, google drives, etc., but not all users have the onedrive or thunderbird folder … for this reason I use filters.

Moreover this picture showes that I have enabled snapshot to avoid any error during backup of used files like word, outlook or any other software (I have installed Duplicati like a service):

Cattura2

I want to specify that the error is appeared only in this server (I have many installation of Windows 7,10, Server 2008R2 and Server 2012R2) but this is my first Windows Server 2016 and this is the first time I have met this problem.

@Emanuele_Bruno your filters still show “include” for Google, Mozilla, etc when I’m pretty sure you mean “exclude”.

Also, in order to utilize snapshots, Duplicati must run with elevated rights.

With multiple servers and problems, references like “this server”, “the error” and “this problem” are confusing. If you’re talking about “uploading from the wrong directories”, after exclude was added:

Filters

In the special case that all rules are include rules (which does not make sense when all files and folders are included per default) Duplicati assumes that all other files and folders are meant to be excluded (this had to be defined as another rule in Duplicati 1.3 but most people found that confusing so we changed that in Duplicati 2.0).

might be the explanation, but it would depend on what’s checked on the source tree. If it’s C:\Users\ shown on the later screenshot (is this the same system that used to have Exclude?), it’s more likely.

My guess is that the goal is to include certain desired folders from user profiles, ignoring any others, however cache exclude caused the “special case” above to end, so all of C:\Users\ flowed right in…

The TEST-FILTERS command can be used to explore filters. I’m not an expert, but find it confusing.

EDIT:

For tests, it’s probably worth setting up an example structure with many fewer files, like this (or half):

C:\tmp\Users>tree /f
Folder PATH listing for volume Windows
Volume serial number is ###-####
C:.
├───User1
│   ├───Documents
│   │   │   document.txt
│   │   │
│   │   └───documents subfolder
│   │           document.txt
│   │
│   └───Downloads
│           download.txt
│
└───User2
    ├───Documents
    │   │   document.txt
    │   │
    │   └───documents subfolder
    │           document.txt
    │
    └───Downloads
            download.txt


C:\tmp\Users>

One thing to be careful of is subfolders. I’d assume the intent is (for example) Documents and below.

You’re right, I can see the full path he’s trying to include in his first post.

I was wondering what Duplicati actually got told. Now we see it, but which issue remains is not clear…

Single-user would be easy. Just check the folders you want. Multi-user needs include and exclude, so requires understanding filters better than web UI might lead one to think. It seems a complicated area which maps closely to the internal representations, e.g. the convention of a folder ending with a slash.

In the small amount I played, it was very hard to say something like “Documents folder and subfolders, but don’t get tricked if someone makes a folder called Documents_and_more – also exclude that one”.

I wound up with a regular expression using the ? operator to handle the subfolders-are-fine problem… Perhaps you’re better with filter stuff? I just use checkboxes (and VSS) so don’t need to use the filters.

For this the reason I have installed Duplicati as a service (I have said that before!)

I have included Google, Mozilla, etc because I want include them :smiley:

Sorry for missing that.
It is possible to run as a service using a regular (non administrative) account. Can you confirm that you are running the service using LocalSystem or an Administrator level account?

In this way?

Cattura

The problem still occurs…

At this point I suspect that the problem is related to the operating system; in the past it had happened that I could not access some files and only after correcting the file system with the chkdsk command I was able to make a backup without errors or warnings …

I have found this post… Could it help?

It explains that in Windows 10 (and I can suppose that it is the same in Windows Server 2016/2019) Content.IE5 is not a shortcut, it is a Junction…

What do you think?

PS I want to clarify that the “template” that I use works correctly in Windows 10 and this problem has never occurred …

Hi ts768, it’s exactly what I want: I have indicated that I want to copy all the contents of the C:\Users folder and I have also added filters to indicate what I want to copy …In reality, the Duplicati software should not even enter in that folder …

Yep, it looks good to me. Although you can confirm for certain by looking in Task Manager. On the Details tab you can add columns for “Elevated” and “UAC”. Here’s what my Duplicati looks like when it is running with elevated rights:

I’m thinking there may be a conflict with your filters. The includes are overriding some of the excludes, perhaps.

Arguably it should because revised configuration:

  1. Said to backup C:\Users\ via the checkbox.
  2. Used includes for subfolders of that (which does not make sense, so got special case above).
  3. Removed the special case with the new exclude, thereby reverting to plan 1 with all C:\Users\

Above is as documented, but I’m having difficulties getting other things to match the documentation.

Maybe someone who has used filters more can assist. I find them far from ideal of “do what I mean” however it would be nice if documentation and reality were closer. The possibility of bugs exists too.

If we’re working on the question above where adding the CacheFiles exclude brought Downloads in, theory from me is above, and is the original checkmarked C:\Users\ request seen later did as asked. Rephrasing that remark, perhaps new exclude is overriding special case of exclude-unless-included.

Hi all, I have found a “workaround”:

Cattura

Unfortunately it is not the solution I was looking for, but I had to give a solution to my client … and for the moment it’s okay … If this is a bug in Duplicati software, how can I communicate it to programmers?

GitHub Issues page is where to file bugs, however you need to make a case that it’s a bug.
Backing up C:\Users\ when you told it to AND used an --exclude is documented behavior.
Some of the stuff that I saw didn’t seem to match the documentation. Feel free to explore…

today I feel more confused than yesterday. I just installed a new Windows 2019 server, and created a single user and configured duplicates for testing.

Immagine02

But there aren’t 69 files!!!

Immagine03

There are only 3 files… what the hell is going on?

To see what is going on (maybe a hidden file problem – I see no dir /ah and I don’t have Outlook), please watch the live log at About --> Show log --> Live --> Verbose and see what paths that shows.

It looks like you’ve told Duplicati to back up C:\Users and then also have an include filter (?) for Outlook. Can you show the other filters you configured on this latest test?

Hi all,
at the end I resolved in this way:

Source data:
image
Filters:
image
Advanced options:
–snapshot-policy=Required

and Duplicati configured as a service (administrator account):
image