Error 403 on backup process


I have an error when I run the backup to my FTP server. This is the full log:

DeletedFiles: 0 DeletedFolders: 0 ModifiedFiles: 0 ExaminedFiles: 5402 OpenedFiles: 5402 AddedFiles: 5402 SizeOfModifiedFiles: 0 SizeOfAddedFiles: 5065295198 SizeOfExaminedFiles: 5065295198 SizeOfOpenedFiles: 5065295198 NotProcessedFiles: 0 AddedFolders: 1626 TooLargeFiles: 0 FilesWithError: 0 ModifiedFolders: 0 ModifiedSymlinks: 0 AddedSymlinks: 0 DeletedSymlinks: 0 PartialBackup: False Dryrun: False MainOperation: Backup CompactResults: null DeleteResults: DeletedSets: Dryrun: False MainOperation: Delete CompactResults: null ParsedResult: Success EndTime: 20/10/2018 6:51:24 (1540029084) BeginTime: 20/10/2018 6:51:16 (1540029076) Duration: 00:00:08.4564837 BackendStatistics: RemoteCalls: 18 BytesUploaded: 4878448807 BytesDownloaded: 4966394 FilesUploaded: 3 FilesDownloaded: 2 FilesDeleted: 3 FoldersCreated: 0 RetryAttempts: 7 UnknownFileSize: 98700745125 UnknownFileCount: 27 KnownFileCount: 6 KnownFileSize: 5577707176 LastBackupDate: 19/10/2018 19:00:02 (1539986402) BackupListCount: 1 TotalQuotaSpace: 0 FreeQuotaSpace: 0 AssignedQuotaSpace: -1 ReportedQuotaError: False ReportedQuotaWarning: False ParsedResult: Success RepairResults: null TestResults: MainOperation: Test Verifications: [ Key: Value: , Key: Value: , Key: Value: [ Key: Error Value: Error en el servidor remoto: (426) Conexión cerrada; transferencia anulada. ] ] ParsedResult: Success EndTime: 20/10/2018 6:59:51 (1540029591) BeginTime: 20/10/2018 6:51:33 (1540029093) Duration: 00:08:17.7054672 ParsedResult: Error EndTime: 20/10/2018 6:59:51 (1540029591) BeginTime: 19/10/2018 19:00:00 (1539986400) Duration: 11:59:51.1783941 Messages: [ Renaming “” to “”, Renaming “” to “”, Renaming “” to “”, No remote filesets were deleted, removing remote file listed as Deleting:, … ] Warnings: Errors: [ Failed to process file => Error en el servidor remoto: (426) Conexión cerrada; transferencia anulada. ]

This is the first run of the backup process, when I run the test connection in the settings it does not show any errors; if I try to connect via FileZilla using the same credentials I can log in with no issues. I have another Duplicati who backup ups in the same FTP server and I have no issues there.

And I get this error when I open the settings for the backup:

Failed to enumerate Microsoft SQL Server databases: Cannot load ‘AlphaVSS.x64.dll’

And I don’t know if this is relevant, but on the home page of Duplicati, on the info displayed for the backup, it shows that the origin is about 4.72 GB in size, and the security copy is 5.19 GB in size.

What could be the problem here?

Thank you!

Do you happen to have MSSQL installed, and are running Duplicati as an administrator? This issue sounds related.

Hello @El.Psy.Kongroo and welcome to the forum!

This AlphaVSS error seems a little mysterious (to me). Some reports even suggest that the installer goofed, so reinstalling Duplicati might help. Others talk about downloads to install the missing (however it got that way) .dll. for some previous articles that likely hit this problem.

For the 403 error, that’s not quoted anywhere. Was it on a popup notification? Your log does show a 426 error, and I’m also a little worried about seeing 7 RetryAttempts unless you’re going over the Internet (risky with FTP). This looks like a networking problem. Were you able to notice the spot in the backup sequence where it failed?

EDIT: Some FTP servers keep really nice logs. You might check yours to see how it viewed what happened. The 426 error is defined (and may or may not be implemented) rather specifically in the FTP protocol spec, however I’m not sure whether it came before or after the 403. If I had to guess I would guess it came after…

Thanks for the reply. I runed another backup process and the 426 error went away, so maybe it was some temporary networking issue as you suggested. As for the missing AlphaVSS.x64.dll I think it’s because of the old Visual C++ version that we have in the server (2008). This missing .dll affects something in the backup process ? Because I don’t know if I can upgrade the Visual C++ version (I’m not the admin of that server) to check if that is the solution.

Thank you for your time!

I think some forum notes provide techniques, scripts, and comments about the .dll and the versioning situation. The people there know way more than I do, so I’ll simply refer you to what they’re stating. Glad to help as I can.