Encountered warnings: Failed to process path!

I have Duplicati installed.
Then I created a backup job to backup my documents and desktop from my Windows 10 laptop to Backblaze B2 cloud store. Configuration was smooth - no problem.
Then I run the job and got some 10 or so warnings. All for files from the same directory. All files are encryption key like. Some are pub, ppk, pem, crt or key.
The error message is:

2022-05-21 15:22:49 +02 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\PATH\TO\DIRECTORY\my_name_2048.pub

or similar.
I have seen some posts here on forum and tried a few things but nothing helped.
Please note that I have three folder filters to exclude some large folders with trash and NO exclusions defined.
Any idea would be very much appreciated.

There should be somewhere a more detailed - if more difficult to read - explanation. Typically in an email status report, after the Limited Errors section should follow a ‘Log data’ section where more info is avaiable in the form of a backtrace, where after repeating the ‘failed to process path’ there is a ‘System.IO.IOException’ followed by a more explicit message. I’d expect a permission error in this case.

You mean this?

Log data:
2022-05-21 20:00:02 +02 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\PATH\TO\DIRECTORY\my_name_2048.pub
System.UnauthorizedAccessException: Access to the path '\\?\C:\Users\PATH\TO\DIRECTORY\my_name_2048.pub' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   at Duplicati.Library.Common.IO.SystemIOWindows.FileOpenRead(String path)
   at Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.<>c__DisplayClass1_0.<<Run>b__0>d.MoveNext()

Yes, that’s exactly the problem. The fact that your backup is running as your user account is protecting the backup to hold confidential data.

If you don’t want that, just exclude the files.

If this is what you want, a bad solution (but easy) is to change the rights on the files. A better solution is to run the baclup as a service since it will run as the System account and as such should have access to all files.

1 Like

I registered Duplicati as Windows Service according to these instructions. It’s very easy.
Then I have restarted my notebook and tried to run the backup again.
And it seems it worked.
Thanks @gpatel-fr.

Migrating from User to Service install on Windows has some steps, but because you’re already done,
please check that you started it with either the --server-datafolder or --portable-mode options.

Windows version updates tend to wipe the SYSTEM profile (thus Duplicati DB).into C:\Windows.old