Empty restore list from local file with encryption

Hi, if I manually download an encrypted backup folder from dropbox, then when I try to restore from local folder, the search for files to restore is empty. I’ve done the same test without encryption, and then the search file box lists all the folders that are backup up. What can it be ? I can restore from dropbox with encryption without problems. So the problem appears when i download the folder to extract locally. Thanks in advance, I need to solve this asap…

Hi @Sergi_Roman, welcome to the forum!

You mentioned needing to do your restores ASAP - did you get that going? If not, is it still needed?

Functionally, you should be able to put the destination backup contents pretty much anywhere (including local) and restore from them (I’ve done this myself) so we should be able to figure out what’s going on, if it’s still necessary.

Hello @JonMikelV , thanks a lot for your help. I have to say that I’ve managed to restore backup from another location, so now there’s no hurry. The thing is that i’ve been trying, but i can’t restore if i download a remote backup manually. I’ve downloaded the folder from dropbox, and when i try to restore from local files, there is nothing to select for restore… I don’t know what can i be doing wrong. If anyone can tell me a possible solution, it would be great. Thanks again and great software !! :slight_smile:

I’m not exactly sure where you’re running into the empty restore list, so here are screen shots of what I did when I tested. Let me know where yours differs (or paste your own screen shot if you’d like). Oh, and you’re welcome for the software!

  • From the main menu I selected “Restore” then “Direct restore from backup files”.
  • Then made sure the “Local folder or drive” Storage type was selected and browsed to the folder with the “destination” files in it:
  • I went through Step 2 (Encryption) and got to Step 3 (Select files) where I selected one of the files:
  • I continued on to Step 4 (Restore options), selected a destination path and the restore went ahead restored the test file

Hi again, I’ve just updated duplicati to version Duplicati -, and tested again. Now it works perfect. I can backup with encryption to dropbox, then manually download the files from dropbox, and restore from local folder. The selection windows now shows the tree of folders/files to choose to restore.

So, good news !! Problem solved !!

Thanks a lot for your help. This is a great project.

Glad it worked after the update, so I went ahead and flagged that as being the solution.

Thanks for using Duplicati!