Email messaged not getting sent

I have tried setting up the advanced features to send emails on error success warning and fatal. Theemails dont get sent and there is nothing in the log files to suggest that its even been attempted. I have tried with a gmail script copied from a previous support message and also with my own mail server. I have tried this on a Mac and on PC.

It took me quite a while to get the email to work, one thing the subject field must be in quotes.

Here is an example of a working setup:
–send-mail-subject=“Duplicati %OPERATIONNAME% report for %backup-name%”

1 Like

I don’t believe that is true… My subject specification doesn’t have quotes around it and it works fine.

@rickfry - if you start a backup job and watch the log in About → Show Log → Live → Verbose, you should see some more detail about Duplicati’s email attempt at the end of the job.

I could not get emailing to work until I put quotes around my Subject as shown above. That’s my experience.

Strange. I have almost the exact same subject line without quotes and it works on all of my systems! Maybe it depends on email provider.

Do you use true GUI or CLI? CLI may need help when an option has multiple words with space between. Programs don’t know where the option value ends. You might say it ends when the next one begins, but maybe something that looks like an option name was meant as an option value. Quoting stops guessing.

Regardless, test on Windows with Export As Command-line as a base failed on %OPERATIONNAME% after I removed the quotes that the Export helpfully gave, because Duplicati thought it was a source path.

I use GUI. Good point about CLI! Plus depending on shell/command processor, you may need special handling for some other characters (percents, dollar signs, slashes, etc)…