Duplicati writes TEMP full!

yesterday i found my C:\ partition on Windows 10 FULL.
As i looked for reason i fount in %temp% some files that point to duplicati.
the wasted space amounted to almost 100 GB !!
How do I find out why duplicati does not delete such temporary files?

i can attach a screenshot if this is possible …

I have the same problem and there is no right answer for your question as I remember. May be you stopped D2 or it stopped by error…

So, I write a script which delete files older some days to avoid this kind of problem.

Can I change the TEMP path from Duplicati to another drive?

What version of Duplicati are you using? Did you customize the Remote Volume Size setting (default is 50MiB), no single temporary Duplicati file should exceed that.

I’m currently using version

For me, the volume size was set to 50GB!
maybe that was the mistake?
I have now set the volume size to 50 MB, hope it is OK?
I’ll test it for a while …

Yes, a 50GB volume is almost certainly much too large. Let us know how it goes with it set back to 50MB.

Note that remote volumes that were already uploaded will stay at the older, larger size. If you are new to Duplicati, you may want to consider starting over from scratch (deleting all remote files, deleting the local database) with the remote volume size set to 50MB.

I have now deleted the old backup folder and the database. The first backup with the new settings is currently running, let’s see :wink:
Thanks for the help!!

1 Like

This type of misconfiguration is too common. Why is the option to change the remote volume size displayed so prominently? I think the default is likely fine for the majority of users. Hiding it in the advanced options could prevent further misuse.

Agreed. Not sure when the link “for more information” was added, but it’s not enough to avoid confusion. I think we should hide this option and leave it in advanced.

Be careful of the interaction between the two ways of setting it. One might think that it’s synonymous with dblock-size, but testing shows that a nonstandard Remote volume size is not shown in Advanced options. They seem to be stored separately, but dblock-size wins if both are set. Sample exported config looks like:

        "Filter": "",
        "Name": "dblock-size",
        "Value": "52MB",
        "Argument": null
        "Filter": "",
        "Name": "--no-encryption",
        "Value": "true",
        "Argument": null
        "Filter": "",
        "Name": "--dblock-size",
        "Value": "51MB",
        "Argument": null


Testing suggests the second --dblock-size is the Advanced options one, and it might not be there if that’s not set. Maybe that’s how the code tells which is which? Regardless, anyone doing a change should look.

Good reminder. I’m not sure how or why there are two methods…doesn’t make sense to me.

Thanks @ts678 for pointing this out. I didn’t know that there were two ways of specifying this.

I’m seeing the opposite behavior (at least when running in the web UI). If I have both dblock-size and --dblock-size set, the --dblock-size value is the one that is respected. This happens here in the code, where options prefixed with -- are considered “overrides”:

Possible typo. I’m not sure I still have the test setup, but if I recall correctly the advanced option added at the end overrode the GUI field (that confuses people, but is always there) called Remote volume size which is always stored in the first dblock-size (the one without double dashes). Does that fit your test and code look?

Yes, the “Remove volume size” gets stored in dblock-size, and the advanced option version is stored in --dblock-size. The advanced option value wins if it exists.