Duplicati stops uploading

Hi,

I started using Duplicati on Unraid to backup my photo’s to B2 storage.
After configuring it, it started uploading the files with no issues. But after a while the speed start dropping. Even to a few bytes per second.

At the moment I have a hard time debugging because the logs don’t show much information. When I select ExplicitOnly in the live log I have the following messages as last ones:

  • Sep 2, 2019 9:29 PM: CommitAddBlockToOutputFlush took 0:00:00:04.003

  • Sep 2, 2019 9:29 PM: Starting - CommitAddBlockToOutputFlush

  • Sep 2, 2019 9:29 PM: Checking file for changes /source/PhotoAndVideo/Foto’s/2017-07-31/DSC07013.ARW, new: True, timestamp changed: True, size changed: True, metadatachanged: True, 7/27/2017 12:14:22 PM vs 1/1/0001 12:00:00 AM

After thes messages, nothing hapens anymore. Does anyone have the same issue?
Thanks

Small update…

I changed the block size to 10MB, now the upload is still running. But I can’t figure out why this is working and 50MB is not. Is anyone else experiencing the same issue and able to fix it this way?

Maybe it’s the combination with B2 storage.

Sorry, I don’t really have a suggestion but I can say that I have had no issues with the default 50MB volume size and uploading to B2.

Working here too, artificially slowed down to see if it broke, and with a dblock that didn’t quite get 50 MB:

Above was at level Retry, which is more informative if an upload issue occurs, otherwise use Information.

You can also look at your job Show log information for one that finishes (e.g. 10 MB) to check the level of:

 "RetryAttempts": 3,

(which in this case were on the download not the upload, and upload glitches may be your main interest)