Duplicati on Windows Server 2016 .NET framework Error

I’m getting a .NET error when installing Duplicati on Windows Server 2016; it has both .NET 6 and 7 frameworks installed, and throws an incompatibility error when trying to install .NET 4.x

I have a very similar Windows 2016 Server that is not experiencing the same issue, with the same (as far as I can tell) .NET frameworks installed.

Any ideas?

You do need NET 4.x for Duplicati. NET 6 or 7 are completely different.

In Server Manager, go to “Add Roles and Features”. Click Next until you get to Features. Does it show NET 4.x as installed?

1 Like

Thanks for the assist.

Yes, it does; it looks remarkably similar to the other server that I was able to get it installed and running as a service.

does the working server have the same new .NET versions installed ? I dimly remember that installing new versions can have adverse side-effects on using old versions.


The functioning server has SKD 7.0.200 installed, the one that’s erroring on launch has SDK 6.0.406 and 7.0.102 installed. I’m inheriting these servers, so I don’t have a good picture of dependencies yet, and don’t want to go uninstalling the later SDKs unless we’re sure I’m not going to break anything.

1 Like

For sure I’m not advising you to change configuration. I’m not sure that it’s possible and that it could be of any use. And the working server seems to have the most recent Sdk anyway.

1 Like

Oh, for sure. Thanks for the input. I think I may try to update the failing system to SDK 7.0.200 and see what happens. I think I can get it to run a Windows Server backup to one of the available fileservers just in case that small point update causes a problem.

How to: Determine which .NET Framework versions are installed (Microsoft)

Current Duplicati needs 4.7.1. Minimum version says Release >= 461308 in

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full

which can be seen in Registry Editor or probably this edit of their PowerShell:

(Get-ItemProperty "HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full").Release -ge 461308

I’m more familiar with non-server, which seem to do well at updating versions.

Install the .NET Framework on Windows 10 and Windows Server 2016 and later

at its top is possibly the exact message you saw wanting 4.7.1. Did install fail?

is very vague, but I don’t know if we’re well-equipped to troubleshoot Windows.

More specifically you need 4.7.1 but might as well run on 4.8 or whatever’s new,
however there was big change at .NET 5 and beyond. Ignore those for Duplicati.


Right. Both are showing previous versions of .NET 4, one works, one doesn’t, and both give errors when trying to install 4.7.x; I can confirm that 4.x (I don’t recall the exact version) is installed on both via Server Manager, and it isn’t 4.7.x, and it works on one, but not the other.

When I tried to install 4.7.x, I got an error that this was incompatible and could not proceed; 4.8 looks like its playing nicely, so we’ll see if it works here shortly.

.Net 4.8 update installed, but it needs a restart, so I’ll have to wait until after business hours to see if this impacts the issue.

Thanks for the assist, folx.

1 Like

.NET 4.8 did it; not sure how I missed installing that the first time around.

Are there buttons on this forum I need to click to give y’all credit?

1 Like

You can mark ts678’s response as “the solution” to help others who may be researching the same issue.

Glad you got it working!

Can’t believe i Missed the solution button.

Thanks all!

1 Like