Duplicati-cli not looking good

So sorry - forgot, in previous posts - give my operating environment:

  • Linux Mint 18.2 Sonya" (Ubuntu Xenial)
  • Duplicati -

Looking for that “repair” utility mentioned in the error message quoted in my previous post, I first tried to see what commands duplicati-cli knows - big problem showed up:

$ duplicati --help
Supported commandline arguments:

–toolkit: Choose the toolkit used to generate the TrayIcon, note that it will fail if the selected toolkit is not supported on this machine
Supported toolkits: winforms, gtk, gtk-appindicator

–hosturl: Supply the url that the TrayIcon will connect to and show status for
–no-hosted-server: Set this option to not spawn a local service, use if the TrayIcon should connect to a running service
–read-config-from-db: Set this option to read server connection info for running service from its database (only together with no-hosted-server)
–browser-command: Set this option to override the default browser detection
Additionally, these server options are also supported:

–help: Displays this help
–unencrypted-database: Disables database encryption
–portable-mode: Activates portable mode where the database is placed below the program executable
–log-file: Outputs log information to the file given
–log-level: Determines the amount of information written in the log file
–webservice-webroot: The path to the folder where the static files for the webserver is present. The folder must be located beneath the installation folder
–webservice-port: The port the webserver listens on. Multiple values may be supplied with a comma in between.
–webservice-sslcertificatefile: The certificate and key file in PKCS #12 format the webserver use for SSL. Only RSA/DSA keys are supported.
–webservice-sslcertificatepassword: The password for decryption of certificate PKCS #12 file.
–webservice-interface: The interface the webserver listens on. The special values “*” and “any” means any interface. The special value “loopback” means the loopback adapter.
–webservice-password: The password required to access the webserver. This option is saved so you do not need to set it on each run. Setting an empty value disables the password.
–ping-pong-keepalive: When running as a server, the service daemon must verify that the process is responding. If this option is enabled, the server reads stdin and writes a reply to each line read
–log-retention: Set the time after which log data will be purged from the database.
–server-datafolder: Duplicati needs to store a small database with all settings. Use this option to choose where the settings are stored. This option can also be set with the environment variable DUPLICATI_HOME.
tomc@DLT ~ $

In the documentation article “Different ways to make a Duplicati backup” it says “For Linux based installations, the alias duplicati-cli is a wrapper for invoking Duplicati.CommandLine.exe.” This does not appear to be the case, or am I doing something very wrong?

Thanks for any help!

duplicati-cli is the actual command. With that command you have the repair option.

Thanks but that leaves a lot of mystery for me. In no sense that I see do I “have” a repair command.

Would not “duplcati repair” need a target? Why cannot I get some documention on the command line?

Throwing myself off the cliff, I tried it anyway:

tomc@DLT /media/tomc/usbHD2-lv2/duplicati-backups $ duplicati-cli repair
Found 0 commands but expected 1, commands:

tomc@DLT /media/tomc/usbHD2-lv2/duplicati-backups $

A big mystery. Doesn’t seem like it should be. Still don’t see a way out.

You can also run the repair command from the GUI. On your configuration you should see a link “run from commandline”. There you can select repair. Or you go to the database link and there you click repair.

Thanks for your response. After some fumbles, and a bit of help, I found the repair function: homepage=>(configuration name)=>Advanced=>database=>repair

The repair errored off. After more fumbles, I manually deleted the backup files, reran my backup and it just ran.