Duplicati CLI allows random passphrase with unecrypted backup

Duplicati CLI is not allowing empty passphrase with unencrypted backup, but it allows random passphrase.

I entered something random into passphrase field and it worked. In the example below I entered number 1.

So there are two gripes:

  1. Empty passphrase should be allowed if backup is unencrypted.
  2. Passphrase should be hidden by stars or be invisible during input.

C:\Program Files\Duplicati 2>Duplicati.CommandLine.exe find file://E:/Duplicati ad_hoc.pdf

Введите пароль шифрования: 1
Listing remote folder …
Downloading file (4.18 МБ) …
Downloading file (4.18 МБ) …
Downloading file (4.18 МБ) …
Listing contents 0 (19.06.2020 16:40:27):
D:\Work_folder\ad_hoc.pdf (85.02 КБ)

Google Translate of

Введите пароль шифрования: 1


Enter the encryption password: 1

so we’re talking about interactive prompting here, not the –passphrase option. Neither one likes empty:

System.ArgumentException: Empty passphrase not allowed

ErrorID: EmptyPassphrase
Empty passphrases are not allowed

For whatever it’s worth, Linux does not echo interactive password entry. I don’t know Windows’ limits.

If not handling the passphrase in any way will do, try adding –no-encryption=true to the command line.

I don’t know if you ever want to use this backup from the GUI, e.g. to more easily select files to restore.
The way to achieve that is to have GUI set things up, then Export As Command-line and edit if desired.

There’s a bit more exported than essential (some values are defaults). You do get --no-encryption=true, along with some others –encryption-module= and –disable-module=console-password-input that were insufficient in my test to attain the no-password-entering goal, but --no-encryption=true by itself worked.

I don’t do much CLI, so someone else may have more to say, but this is what seemed to work for me…

OK. Thank you. I’ll modify exported script.