Duplicate hangs eternally on 'Deleting unwanted'

On one of my system, I seem to have been hit by the ‘stuck on deleting unwanted files’ bug. It has been in this state for at least 10 days now (though the system has been turned off for a long time). I tried restarting the duplicati service (I am on macOS, version 2.6.0.3) but so far nothing I have done has any effect.

I’ve read some of the other posts by people who have been hit by this. So far without anything that I thought I could do. As it is now, duplicati on this system is completely. nonfunctional.

Instead of deleting this, I’ll put in a reply. It turned out that sudo launchctl unload /Library/LaunchDaemons/com.duplicati.server.plist actually did not stop the service which kept running (hanging) and that there were actually two services running:

    0 41559     1   0  20 20 34243772    284 -      SN     ??    0:02.58 /opt/local/bin/mono /Applications/Duplicati.app/Contents/Resources/Duplicati.Server.exe --webservice-port=8200 --log-file=/Library/Logs/duplicati_server.log --log-level=Information --verbose=true
    0 41564 41559   0  20 20 34551856  90844 -      SN     ??   87:07.57 /opt/local/bin/mono-sgen /Library/Application Support/Duplicati/updates/2.0.6.3/Duplicati.Server.exe --webservice-port=8200 --log-file=/Library/Logs/duplicati_server.log --log-level=Information --verbose=true
    0 64870     1   0  20 20 34150428   3208 -      SNs    ??    0:00.03 /Applications/Duplicati.app/Contents/MacOS/duplicati-server --webservice-port=8200 --log-file=/Library/Logs/duplicati_server.log --log-level=Information --verbose=true
    0 64873 64870   0  20 20 34250392  30648 -      RN     ??    0:01.38 /opt/local/bin/mono /Applications/Duplicati.app/Contents/Resources/Duplicati.Server.exe --webservice-port=8200 --log-file=/Library/Logs/duplicati_server.log --log-level=Information --verbose=true

The situation apparently had been created by updating via the web UI.

After really killing both and restarting the service, there was an error report of 88 remote files missing and the option to run repair. This apparently worked after which I was able to run backups again.

This seems to be in line with the experience mentioned in the Github issue (link is to a specific reply in the thread): CompactHandler.DoCompact uses inefficient queries on CompactReport · Issue #4662 · duplicati/duplicati · GitHub

Hopefully this will be resolved in a future version!

Out of curiosity how did you trigger this issue? Did you change your retention settings, purge some data from your backups, or enable compaction after it was disabled for a while, or something else?

I don’t exactly recall, but probably this was the other backup (you know about the one I am still having warning issues with) that was hit by a backend corruption issue and required repair.