Dupicati HTTP json data is null

Hi, we have configured several backups with duplicati and setted up http post json reports to our backend. We have a computer that sends “null” as the json data. In other computers we figured out that the server URL parameter needed to be befolre the json parameter. If we change that order duplicati sends “null” but this computer is setted up as the ones that work correctly. Any clues?

Is this command line? I don’t think anything is supposed to be order dependent, but quoting can sometimes cause later options to get sucked into earlier options and disappear. Especially likely on Windows because trailing slash double quote needs to use two trailing slashes, otherwise you sucked quote in and kept going.

How exactly such an issue turns into a null report is unclear, and I can’t find it reported. Feel free to search.


If true command line setup is hard (too many options to pick or miss), try GUI then Export As Command-line to run (but don’t run the CLI backup at the same time as GUI – do one or the other at any given time).

1 Like

Thanks for the reply!

1- Yes, its Windows.
2 - We have setted it up vía web GUI.
3 - We need to set the HTTP variables in certain order so duplicati doesnt send “null” to our backend.

Any approach to not to have to set the order in windows GUI?

This is a little clearer than before. The order displayed seems to be alphabetical, but you’re speaking of the order in which Advanced options are entered I guess. Regardless, I can’t find any reports of such an issue, either in the forum or GitHub Issues. Feel free to search. I also can’t reproduce it, though my web server is simply an nc -l on Linux – it’s enough to see what Duplicati is sending, and either entry order sends data.

Please see if you can reproduce this using the simplest possible backup, with minimal options, and ideally without a web server. If you can get very small and simple steps, you can file an issue with the exact steps.

If I read original post correctly, you found a consistent failure (which I can’t get) with one order, and reversal fixes all systems except one. Splitting the issue, what might be different about the one particularly bad one?

If you get an easy test case, you can also do Export As Command-line and run it at a Command Prompt to see if the order behavior applies there. If so, keep any punctuation, remove private info, and post whole line.

1 Like

After exporting the command and comparing the good ones with the ones with null as result, we figured out that my coleague was copy-pasting the variables as “text” to the GUI and he had mail format variable instead of http format. Mistery solved.

1 Like