Download links not working anymore

The download links on the website do not work anymore, they are just giving 502 Bad Gateway errors. Same happens when checking if there is a new version from within the Duplicati web application.

Best Regards


I’m having the same issue. Tried yesterday from Chrome and IE. Then again a few minutes ago.

Same here. You can download from here though:

1 Like

Thank you! I previously looked on but the Click here to download the latest Duplicati 2.0 beta release link just brought me back to the same page that wasn’t working. Your link did work and I have it installed now.

Hi @asdfasfadf424, @vincentertainment, and @Ewoud welcome the forum - thanks for letting us know about the links and providing a workaround!

I just checked the top 4 links and they all worked for me with Firefox but not Chrome or Brave.

Hopefully @kenkendk or @kees-z can take a look & get it resolved.

For me, it’s been kind of half working (and I didn’t realize that it was browser-dependent either). My Firefox would basically land me on the GitHub page, so no big deal. Downloads from there can be done. Duplicati manages to find the sort-of-update (it’s plus a warning) and pop up a notification…

This looks wrong though (the second part is normal, but the 502 error is not – can we auto-monitor for it?)

C:\ProgramData\Duplicati\duplicati->Duplicati.Library.AutoUpdater.exe check
Error detected: System.Net.WebException: The remote server returned an error: (502) Bad Gateway.
   at System.Net.WebClient.DownloadFile(Uri address, String fileName)
   at Duplicati.Library.AutoUpdater.UpdaterManager.CheckForUpdate(ReleaseType channel)
Error detected: System.Net.WebException: The remote name could not be resolved: ''
   at System.Net.WebClient.DownloadFile(Uri address, String fileName)
   at Duplicati.Library.AutoUpdater.UpdaterManager.CheckForUpdate(ReleaseType channel)
No updates found


Sounds kind of like these, though I don’t recall the resolution.

I just tried again some links (from Duplicati). Windows download sometimes works, sometimes gives a 502 error, osx download link always gives a 502 error. Could it be some caching and/or timeout issue on the webserver level? I guess there is a webserver between the actual backend server(s) and the client. Maybe it is also trying to download from a certain mirror with that mirror beeing down?

I know that downloads from github work but it is still not a good first time impression for new users

Best Regards


In addition to proposing an auto-monitor for this be created (because it seems a very frequent problem), having multiple people able to actual restart things (if that’s what it takes) would seem an excellent idea.

Extending the same plan to other (fortunately more reliable) server infrastructure could also be planned.

Download links do not work for me either. Sometimes the browser is able to download 300-800 KB and then fails, sometimes 502 error appears. Windows 10 x64, Chrome 76, Edge

Although the update server needs fixing by whoever can do so, does downloading from GitHub work?

You didn’t say whether your link was from github or not, and for me it varies. Hover mouse over a link.

Doing a comparison test would help confirm (in a different way anyway) that update server is not well.


Thanks. I’ve seen this situation before, although not recently. At least there’s some way to do a download.

I’m not sure if Duplicati’s built-in downloader (part ofautomatic update system) can use alternate servers. does seem to be a recurring failure point, especially 502 Bad Gateway below.

FWIW manual Duplicati.Library.AutoUpdater.exe check is still throwing the 502 error for me now.

Download links point all to github site was a previous round of me studying the JavaScript to debug issue. is at the moment again giving


Any NGINX (or maybe server) experts out there? Possibly your special expertise could benefit the project.

Still getting the same error when trying to upgrade a previous version of duplicati through the web interface

Sorry for the trouble! I dist-upgraded the server and tested that all was working afterwards. Unfortunately it only kind-of worked due to a missing docker-based monitor not starting automatically.

It should be fixed now!

1 Like
  1. Aug. 2019 11:34: Error in updater
    System.Exception: Invalid file size 274800, expected 15085655 for
    bei Duplicati.Library.AutoUpdater.UpdaterManager.DownloadAndUnpackUpdate(UpdateInfo version, Action`1 progress)

When I copy the link in my Browser, I get a 502-Bad Gateway

Restarted it, and it works for me now.

And it looks like it’s broken, again :grimacing:


It’s 502 Bad Gateway again

Download page saying ‘Bad gateway’ had some analysis by me, and an earlier attempt to notify of the issue. Perhaps I should repeat the call I made there, in case an NGINX expert would like to offer admin help on this.

Seems OK now. Maybe something was done. The download page links for individual OS versions are now pointing to (as normal) and they work nicely (at least on two OS versions I sampled).

If the OS-versioned links at the top of the screen still point to github, you could try a hard refresh of browser.