Crash after Update

After updating Duplicati to version (running on an Ubuntu box), the software doesn’t start anymore. The error message is:

Unexpected error: System.MissingMethodException: Method 'HttpWebRequest.set_ServerCertificateValidationCallback' not found.
  at Duplicati.GUI.TrayIcon.HttpServerConnection.PerformRequestInternal[T] (System.String method, System.String endpoint, System.Collections.Generic.Dictionary`2 queryparams) <0x403e83d0 + 0x005c7> in <filename unknown>:0 
  at Duplicati.GUI.TrayIcon.HttpServerConnection.PerformRequest[T] (System.String method, System.String urlfragment, System.Collections.Generic.Dictionary`2 queryparams) <0x403e7d20 + 0x00113> in <filename unknown>:0 
  at Duplicati.GUI.TrayIcon.HttpServerConnection.UpdateStatus () <0x403e7b80 + 0x0003b> in <filename unknown>:0 
  at Duplicati.GUI.TrayIcon.HttpServerConnection..ctor (System.Uri server, System.String password, Boolean saltedpassword, Boolean dbPasswordSourceDatabase, System.Collections.Generic.Dictionary`2 options) <0x403e66c0 + 0x003a3> in <filename unknown>:0 
  at Duplicati.GUI.TrayIcon.Program.RealMain (System.String[] _args) <0x4031f3e0 + 0x00f1b> in <filename unknown>:0

Finally, I deleted Duplicati completly (apt-get purge duplicati) and reinstalled - same error message.

Any hint is appreciated, thanks in advance.

I edited your post to improve the formating. (Just added ~~~ before and after the output you pasted, see here for details).

Did you install as a service?

I downloaded the deb-file and did an “dpkg -i duplicati…deb”. It is not a Windows installation.

Oops, sorry - that was a dumb question. I haven’t done a Linux based install yet (outside of Docker) so didn’t realize it apparently always comes in as a service there.

From what version where you upgrading, was it in the v1 line?

Hmmm, the problem is “solved”: I deleted my Duplicati configuration and restarted from scratch - now it is working.

can you describe where and what file you deleted ?

I don’t suppose that file happened to be in any of your backups so it could be resurrected and reviewed as a post-mortem? :thinking: :

I deleted the folder .config/Duplicati and rebuilded my backup configuration. Now it works again.

You most likely had an update installed in there. The error was introduced as a fix to SSL certificate override, but turned out to not work on some installations (I assume an old(-ish) Mono version is missing the method). The latest canary does not use the method anymore.

Thanks a lot for this explication!