Connection lost issue on Synology

Are you connecting from with the DSM manager or a ‘remote’ machine?

I was connecting to DSM web interface on the LAN using…

Thanks for your response.

I discovered was that if I log into the DSM web interface from

Then duplicati opens.

Initially, when it opens it throws a blank popup window which I cannot acknowledge. Next I close/reopen duplicati and I get the basic interface. Sometimes I have to close/reopen to see all the dropdown options… for example the dropdown from which to select Dropbox, etc.

I tried logging in to DSM via DDNS and it too fails. So for now, only the LAN IP seems to work.

I have managed to run a backup (manually) to Dropbox and to restore from there. My hope is to get duplicati working next with B2 and Google Drive via the Synology NAS package.

1 Like

Is that a typo or is it really what shows up in the address bar (no domain or IP address)?

Also, what happens if you change the “https” to just “http”?

That was a formatting error (darned brackets). It should have read…
Here’s the error popup I get frequently…

Check out this post:

Thanks for pointing me to that post What seems to work for me now is to log into the DSM interface using my LAN IP (I presume I could do this via VPN, but haven;t tested). For example…


When I open the duplicati gui I initially get a blank error popup window, I close that, and then close the duplicati window. Then I reopen the duplicati gui and all is well. No error popup, and the dropdown selections for creating a new backup are then active.

I do get warnings, which seem to be about certs, but otherwise backup/restore/encryption seem to be working on Dropbox and B2.

I also saw this on Synology after upgrading from Duplicati to I ran the command at the bottom (Synology section) of this page to resolve it:


I’m having same issue on DSM 6.2.1 and Duplicati The workaround posted above doesn’t work for me.
The only thing that works is starting the server manually.

More info: Using chrome to inspect the traffic here is what I see repeating periodically on attempted reconnect every 15 seconds

Request URL:
Request Method: GET
Status Code: 404 Internal server error
Remote Address:
Referrer Policy: no-referrer-when-downgrade

Request URL:
Request Method: GET
Status Code: 403 Administrator login required
Remote Address:
Referrer Policy: no-referrer-when-downgrade

Hmmm…I don’t recall seeing the “Administrator login required” before.

Do these seem to show up in pairs?

Yes, these show in pairs every 15 seconds on automatic reconnect attempt.

Are there any other logs I can grab? Where are they located?

When I open the URL in new windows (right click open in new window) I get only one of the errors repeating every 15 seconds on reconnect

Request URL:
Request Method: GET
Status Code: 403 Administrator login required
Remote Address:
Referrer Policy: no-referrer-when-downgrade

SOLVED!!! Mea culpa, I apologize for wasting time here. I did not have my user in http group. The user is admin level but still needs to be in http group.
After adding user to http group I got one message about missing XSRF token and then when I re-opened the window all is working. No more lost connection, reconnecting messages.

Step 3) in install instructions here is really important!

Glad to hear you figured it out!

And don’t worry about “wasting time” - your post will likely help many people save time going forward. :slight_smile:

I’ve done this – I’ve added all the users to the http group just out of curiosity and it still gives me the “Connection lost” error message.
Any ideas?

Dear community;

I have a DS416 running DSM 6.2.2-24922 Update 2.
Mono 4.6.2-0096 (provided through Synology appstore) is running.
I am with the current Duplicati version (and also tried,

  1. Initially I looked through why backup stopped -
    config files resided on /root/.config/Duplicati and the volume has been completely filled by duplicati Does this corrupt the sqlite databases?.

I found some hint to change the default configuration as cmd line parameter but I am unsure how to change this configuration through the GUI. Neither did I identify the relevant configuration file.

  1. Then I moved these files to /volume1 and tried to set a symlink
    cd /root/.config
    ln -s /volume1/@duplicati-config Duplicati
    Here I am not sure whether Mono / synology work correctly with symbolic links.
    At least I was able to secure my databases this time.

  2. Now I am stuck; even without my (possibly corrupted) databases, The server provides the menu, but blinds it out with the error message “The connection to the server is lost”. I repeatedly run into this, even with a normal directory being created by the installer and the default files.

  3. process view:
    After starting the server using the GUI, it will idle some time and the GUI reports afterwards ‘stopped’. In the process tree I find /volume1/@appstore/Mono/usr/local/bin/mono-sgen /volume1/@appstore/Duplicati/Duplicati.Server.exe
    This remains also after running /sbin/initctl stop pkgctl-Duplicati manually.

  4. I was not able to identify the path of the Duplicati log file. dmesg does not show relevant information.
    I did not find readable information in /volume1/@appstore/Duplicati nor /var/log

  5. If validated the http user group (following How to install Duplicati on Synology / DSM)

I should state that duplicati package has run good for 9 months before running into this.

Any ideas?


I learned it is actually about the client security settings, see:

ssh on your synology
mono /volume1/@appstore/Duplicati/Duplicati.Server.exe --webservice-interface=any --webservice-port=5600 --webservice-interface=* --webservice-allowed-host=*

Works here.

Importing the CA certificates
ssh on your machine
sudo su -
/var/packages/Mono/target/usr/local/bin/cert-sync /etc/ssl/certs/ca-certificates.crt

Thank you. I ran into the same problem when changing Duplicati access from SMB to WebDAV with a new created user on my Synology NAS. -> SOLVED with your important hint!

1 Like