CLI --allowed-ssl-versions cmd not working


I’m trying to limit connections to only TLS 1.2 and higher via the CLI, though it doesn’t seem to be taking or I’m doing something wrong of course.

When I try the command with the selected versions I need, I just get spat back the help response for the command.

How to use the Duplicati Command Line tool gives the available commands, for example backup.

Duplicati.CommandLine.exe backup <storage-URL> "<source-path>" [<options>]

That’s not a command, it’s an option for a missing command. Please type command and options.

An easy way to set this up and not have accidents of missing options is to set up in the GUI, then
Export As Command-line, or if you already have a full command, add the option onto current ones.

If you might ever use the GUI, e.g. instead of a CLI restore command, keep the setups compatible.
True CLI (as opposed to GUI Commandline) is independent of GUI and needs all settings supplied.


Thank you for the reply.

I was trying to add this configuration not to the backup jobs themselves but as one the default options for Duplicati as a whole, as if when in the UI selecting settings on the left and then setting the configuration under default options.

–parameters-file might help, but the server has a Duplicati-server.sqlite to track defaults, and CLI doesn’t.