Choosing different drive letter


#1

I’m running 2.0.3.3 on windows 10 as a service using the GUI. I’m trying to backup to a local drive that is not C. It is G. But the GUI only shows C. So when I type in the path manually and test I am told the path doesn’t exist and do I want to create it. I cut and paste the path right from File Explorer.

I already did this once when duplicati was running as an app and everything worked fine. But now running as a service I can’t use any path but C.

What gives?


Feedback from a new user - mainly Windows use
#2

It sounds like your G drive is a virtual drive, such as a network share mapped to a drive or a local folder mapped to a drive using the SUBST command. Basically, the user you have set to run the service does not have the same drives mapped as your local interactive session. You will want to backup the true source of your G drive, or change the user set to run the service to your own username.


#3

Hi @pribis and welcome to the forum!

This might take some guessing. First, I’ll say it works fine for me, using a USB thumb drive formatted FAT32.
Would you happen to have one to see if it does the same thing? That seems an easy way to rule out ACLs.

Also note that if the original situation involved a pluggable drive, plug it in before adding its job, to show it…

I have a CD reader with a CD in it, which I can view in File Explorer, but Duplicati wisely (?) doesn’t show it.
So possibly there’s some kind of filtering going on, to avoid showing drive letters that can’t be written onto.
.
Did you happen to let it try to create the path? Or if that feels risky, let it make a folder next to the real one.
If you try it and get a failure, the specific problem that occurs during the creation attempt might give a clue.

Note the Windows drive letters are per-user. Differences may show up mostly on shares or subst (I tested).

The next best test I could try short of setting up a special pluggable drive was to remove permission from a
folder on my hard drive. I took it down to just me using right click and some fancy access control list work…

Got it in File Explorer, copied and pasted to Duplicati, which didn’t find it, and (when asked) couldn’t create.
I think the “does not exist” message might go off for other cases, such as “can’t even get there to find out.”


#4

@pribis I have the same problem as you.

@ts678 This issue is specific to a mapped network drive, not a local drive. Meaning a bit different to your test.
When “run as a service” is in use we cannot access the network from the user the service is logged in as.

@TPSMono when I am mapping the network share I have to login with specific credentials. net use S: \\computer\share /user:barney password1

So… how do we get the service running with a user who has both SYSTEM access for locked files and network access?

I have tried to start the service as SYSTEM, Desktop, the user… but the Duplicati GUI still fails to acknowledge an S: drive.

Any ideas anyone?


#5

In my earlier reply, I mentioned that you will want to backup the true source. For best results, you really want to be running Duplicati on \\computer itself to back up those files from the devices physically attached to \\computer and not your current workstation.

So what if \\computer is a NAS device with no OS to run apps or maybe you do not control \\computer so you can’t install software there? In those cases, you will want to backup the path \\computer\share\ not the drive letter. Duplicati is unable to browse network paths in the GUI as far as I can tell, for both Source and Destination selection. Just push the 3 dots and select Show advanced editor then put \\computer\share\ in the Source folders box. To provide network credentials, you will need to create a batch file with this command:

net use \\computer\share /user:barney password1

Then you can use the Duplicati backup option “run-script-before” under the Options tab to run this batch file before it starts any operation related to that job. If you are concerned about storing your network credentials in a plain text batch file, you can use a powershell script instead, which can use encrypted strings to store the password but its a little more technical. I just tested this with 2.0.3.3_beta_2018-04-02 on Windows 10 Pro running as a service with a backup account that has interactive logons disabled.


Lose settings when changing service user account
#6

Here I suggested “net use” was not necessary, which also avoids the plain text credential issue. Can any try? Reporting back to the link above (positive or negative) might be useful. The topic here began on local drives. Perhaps @pribis could clarify what that meant. What variety of local drive, and how and when was it added?

I also commented on possible inability to browse network paths. See the remarks on “Network Neighborhood”. My systems are all too new to do “Network Neighborhood”, so any Duplicati test will require an older Windows.

I also pointed to Microsoft documentation supporting what we’ve said here – letters are not globally assigned. Despite the Microsoft warnings, the new letter from my USB drive showed up everywhere - including Duplicati.

I’m trying to summarize here too because maybe this thread has wandered, but only @pribis knows for sure.