# Checking errors, related to #1400. Unexpected result count: 0, expected 1

**URL:** https://forum.duplicati.com/t/checking-errors-related-to-1400-unexpected-result-count-0-expected-1/5876
**Category:** Support
**Created:** [January 3, 2019, 7:19pm UTC](https://forum.duplicati.com/t/checking-errors-related-to-1400-unexpected-result-count-0-expected-1/5876 "2019-01-03T19:19:24Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![johnvk](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/f17d59/32.png) [@johnvk](https://forum.duplicati.com/u/johnvk)
#### Post date: [January 3, 2019, 7:19pm UTC](https://forum.duplicati.com/t/checking-errors-related-to-1400-unexpected-result-count-0-expected-1/5876/1 "2019-01-03T19:19:25Z")

</div>

Error in my log:

```
    2019-01-03 00:37:29 -05 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-CheckingErrorsForIssue1400]: Checking errors, related to #1400. Unexpected result count: 0, expected 1, hash: mzp5GXIVXICmXDUaGPQ6T0RBjJd6FUvGhv+6IHUcRV8=, size: 68544, blocksetid: 63134, ix: 47, fullhash: 6xvaiAfAUnq3x1pjPRmcpeCoyKY8L/mMClwsTQRhD8Q=, fullsize: 4881344,
    2019-01-03 00:37:29 -05 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-FoundIssue1400Error]: Found block with ID 253058 and hash mzp5GXIVXICmXDUaGPQ6T0RBjJd6FUvGhv+6IHUcRV8= and size 52128
]

```

These are related to git issue [Failed to process path: xxx =\> Unexpected result count: 0, expected 1 · Issue #1400 · duplicati/duplicati · GitHub](https://github.com/duplicati/duplicati/issues/1400). I wasn’t sure if I should post here or there so I posted here.

Some notes. I have the default `--snapshot-policy = off` which I will turn on for the future. I think default should be `on`, but that’s just me.

And I know it’s off (well, at least I think so) because I also get these warnings:

```
    Failed to process path: C:\Users\USER1\NTUSER.DAT,
    Failed to process path: C:\Users\USER1\ntuser.dat.LOG1,
    Failed to process path: C:\Users\USER1\ntuser.dat.LOG2,
    Failed to process path: C:\Users\USER1\AppData\Local\Microsoft\Windows\UsrClass.dat,
    Failed to process path: C:\Users\USER1\AppData\Local\Microsoft\Windows\UsrClass.dat.LOG1,

```

Interestingly, I did NOT get these errors first time.

I am trying to backup two Windows user trees.

First time, ran as USER1 un-elevated/not-prived and I could not backup USER2 cuz no access.

Second time, ran as USER1 with `Run as administrator` and I could then backup USER2 but I got the errors and warnings above.

So with no snapshot perhaps this is simply that files changed between start and end of backup.

---

<div class="post-metadata">

### Author: ![johnvk](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/f17d59/32.png) [@johnvk](https://forum.duplicati.com/u/johnvk)
#### Post date: [January 3, 2019, 10:13pm UTC](https://forum.duplicati.com/t/checking-errors-related-to-1400-unexpected-result-count-0-expected-1/5876/2 "2019-01-03T22:13:36Z")

</div>

Indeed, adding the advanced option `--snapshot-policy=on` to my backup removed my errors and warnings.

---

<div class="post-metadata">

### Author: ![JonMikelV](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/j/439d5e/32.png) [@JonMikelV](https://forum.duplicati.com/u/JonMikelV)
#### Post date: [January 4, 2019, 1:47pm UTC](https://forum.duplicati.com/t/checking-errors-related-to-1400-unexpected-result-count-0-expected-1/5876/3 "2019-01-04T13:47:08Z")

</div>

I’m not sure how the #1400 error is related to snapshots but if that solved the problem, great!

The reason snapshots aren’t enabled by default is because not everybody runs as a privileged user so they would all get warnings/errors about not being able to take a snapshot.

I’m marking your post as the solution - please let me know if you disagree.

---

<div class="post-metadata">

### Author: ![ts678](https://forum.duplicati.com/letter_avatar_proxy/v4/letter/t/8491ac/32.png) [@ts678](https://forum.duplicati.com/u/ts678)
#### Post date: [January 4, 2019, 2:40pm UTC](https://forum.duplicati.com/t/checking-errors-related-to-1400-unexpected-result-count-0-expected-1/5876/4 "2019-01-04T14:40:33Z")

</div>

> [@JonMikelV](#):
>
> I’m not sure how the #1400 error is related to snapshots but if that solved the problem, great!

I haven’t heard that anyone knows why this old error is back again, but the best-informed guess might be

> [@New warnings/errors occurring after updating to 2.0.4.5](https://forum.duplicati.com/t/new-warnings-errors-occurring-after-updating-to-2-0-4-5/5602/2):
>
> The #1400 refers to this issue: It seemed to happen when reading files that we actively being changed. Since the file shown is the transaction journal for the backup, I think this is the case as well.

and to extend the thought (at my own risk), if a snapshot freezes the file view, that might avoid the error…
