Changed from app to service: backup no longer found

#1

I’ve been running as the app with the task icon. this has been running, but I want to start backing up my outlook.pst file so I need VSS support.

I converted over to using the service, following the how to. While the service does run, and I can attach to it with the web browser. The backup is no longer found.

I know it is there because I can stop the service, and restart the application and it re-appears. How do I get my backup to work in service mode?

thanks
david

0 Likes

#2

The local database is stored in the users folder, under %APPDATA%Duplicati. When you run as a service, you are using the SYSTEM user instead of your normal user. Simply move the Duplicati folder (particularly the Duplicati-server.sqlite file) into the %APPDATA%Duplicati folder for the SYSTEM user, and then start the service.

0 Likes

"Invalid or missing backup id" after moving from tray to service
#3

Can you verify that the C:\Windows\System32\config\systemprofile\AppData\Local\Duplicati folder referenced in step 2 of the #howto contains at least the following:

  1. dbconfig.json file
  2. Duplicati-server.sqlite file (note that this may have a different name but still end in .sqlite
  3. control_dir_v2 FOLDER

If all those are in the folder, could you also check in the ROAMING equivalent folder at
C:\Windows\System32\config\systemprofile\AppData\Roaming\Duplicati\?

Some older posts I’ve seen mention that folder, but since it wasn’t what I experienced I didn’t document it there. However, it’s possible individual machine settings could affect where Duplicati ends up storing things.

If you find them there I’ll add a comment to the #howto and maybe we can even work at figuring out why they went to different places. :slight_smile:

0 Likes

#4
 C:\Windows\System32\config\systemprofile\AppData\Local\Duplicati 

It does not exist so I copied the one from over, but windows wigged out and now I’ve lost the entire directory. Gone, no where to be found. Guess it is time to figure out how to adopt a backup.

thanks though,
david

0 Likes

#5

If you followed the video found on this site about installing duplicati as a service I think the correct destination dir would have been c:\Program files\Duplicati 2\data.

Its my understanding that its the default location for the --portable-mode. (64-bit Windows)

Hopefully you can recover from this.

0 Likes

#6

OK that area does exist and it does have a Duplicati-server.sqlit, .bakcup and .sqlite.

david

0 Likes

#7

I’m recreating the backup, from the server version. It does not see my UNC paths. Says they don’t exist. If I switch back to the desktop application it sees them just fine.

Is there something special I need to do to get UNC paths to work in the server?

thanks,
david

0 Likes

#8

Not sure, I am new at using duplicati also. So following my advice might not be a good idea.

Anything in the …Duplicati 2/data folder at this point would be basically a blank setup. Just like it created for the user you are currently running underr. If you can get everything set back up correctly under the user account you should then be able to copy that into the Duplicati 2/data directory.

I would back the data dir just in case. I haven only done limited disaster recovery test on very small backup sets myself.

Another option might be to use the option --server-datafolder=xxxxxxxx and set it to the current location of users file mentioned earlier in this thread. DO NOT use the --portable-mode also. Note: you will probably have to setup the service again for this to work.

Hopefully this helps.

Good luck.

0 Likes

#9

Working with UNC paths from a Service can be a bit tricky as the service often runs under a different account that the user login.

I’d suggest a simple test would be to go to the “Log On” tab in Properties for the “Duplicati Service” in Windows Services and change the “Log on as” setting from the likely “Local System account” to “This account” and fill in your login information. I expect that will solve the UNC problem (as the “Local” System account is just that - local focused, not network).

HOWEVER - this is just a test of the UNC issue as it will likely bring back the inability to back up the outlook.pst file as you’re again running under the same permissions as a when you were in the user install.

Oh, and sorry about the folder reference before - I guess I didn’t realize you were using --portable-mode.

0 Likes

#10

I recovered the backup, then copied the files to the --portable-mode area.

I then added my user login/password to access the UNC path and it all works.

I am now running as service with VSS enable for outlook.pst backup saving to a UNC path.

thanks for all the help,
david

0 Likes

#11

Glad to hear it!

If there were any particular posts that helped get things working for you, it would be great if you could :heart: them - and even greater (more great?) if you could pick one to check the :white_check_mark: on to flag the issue as resolved. With those few clicks you could be helping the next person to come along with a simillar issue. :+1:

0 Likes