Can't complete backup due to unexpected difference in fileset

Every time I attempt to backup, I get an error:
Unexpected difference in fileset version 4: 12/25/2018 1:00:01 AM (database id: 24), found 151488 entries, but expected 151489
Repair database completes without warning or error. Even after repairing the database, I get this error again. Is there something else I can to resume backing up?

What usually works is deleting the troubled version. Hopefully its neighboring views cover restores enough.

Backup failing due to unexpected difference in fileset describes steps in more detail. Modify it for version 4.

Thanks. It appears that deleting can only be done with the command line, correct? I’m attempting to delete specifically version 4 with
duplicati-cli delete file:///[path_to_backup] --version=4
It’s been running for a couple hours now with no visible feedback. Is this something that could take days?

It’s command line, but the easy one to use is the one for that job in the GUI, otherwise you have to match all relevant options (for example say where the database is, give any encryption information, and so on). Doing Export as Command-line is best for the path you showed. Either way, there’s some format tweaking required.

Are you sure something’s actually running, e.g. is mono using CPU time, or is something keeping disk busy?

The version delete (if it got going, and if it did not I’m not sure why, but possibly due to so much missing info) shouldn’t take a huge amount of time, but it sometimes might free up enough space that a compact runs too. Right now it’s a little late to add logging, but if you restart you can add –console-log-level=Information to see somewhat more about what’s going on. If you do it in the GUI I think the server log can also give live updates.

Replying here so I don’t start my own thread. I’m on I just got an “Unexpected difference in fileset” error on version 3 of one of my backup jobs that I had previously wiped and recreated, so everything was totally fresh and running for a couple of weeks until this failure.

The error was in version 3 (out of 4, numbered from 0 to 4). I followed the steps to delete version 3 which deleted a bunch of files and then returned status 0, which I assume means “OK”. Then I tried to run the backup again and got an unexpected difference in fileset version 1.

I deleted version 1 (same result code 0), re-ran the backup, and got an unexpected difference in fileset version 0. Then I deleted version 0 and it is backing up. Looks like version 2 was OK and all the others were bad?

I’m running the same job to 2 local destinations as well with no issues. This one has a destination on Dropbox, in case anyone else has an issue like this and that turns out to be meaningful. I have 6 other jobs where Dropbox is the destination and I haven’t had this issue though. Bit of a mystery.