Can not restore files

Using Duplicati for Windows, when starting a restore I am presented with three choices. I tried two of these:

  1. The one named with the name of my back up job (third in the list)
    After “Fetching path information …” this fails with this error

Failed to connect: database is locked database is locked

I have tried ending duplicati task in task manager and also rebooting the computer, I still get this same error.

  1. The I tried “Direct restore form backup files …” (the first option)
    This seems to work and allows me to pick the files I want to restore and then at the end I get the error

Waiting for task to begin

I have left it for several hours, it never begins.

Background info:

  1. Backup data is on a local NAS device
  2. There is no encryption set
  3. Data set is large, about 2.5Tb
  4. Duplicati db is also quite large about 20Mb

Any help would be appreciated, I am just trying to restore about 20 files in one subfolder.


The first option seems far more logical in your case, however the error message does not.
Did you check that you are not starting Duplicati in direct mode while there is a server installation running in the background ? server mode is usually on port 8200 while direct more is on port 8300. If Duplicati is running in server mode (you can see that by running netstat /ab in administrator window, if there is something on port 8200 it is that), you should connect on port 8200 (http://localhost:8200)

Make sure that Duplicati is not doing something else (such as a backup) at the time you run restore.

Your screenshot is reproducible here if I try to restore during a backup which is visible on status bar.
To be extra sure, you can view About → System info and see if there’s any activeTask before start.

Above test used a restore of a different job than the running backup. If I use same job, I get first error.
While I don’t know if you’re in either case (please check), Duplicati has limits on simultaneous action.

The cases I tested are using one Duplicati where actions interfere, but you can check for multiple too.
To have a Windows service installation, you would have done a Duplicati.WindowsService.exe install.
If you never did that, then the URL localhost:8300 test will probably get nothing, and you’re on 8200.

EDIT: Using Duplicati from the Command Line could probably do this too, but only if you actually run it.
Both this and the service usage would probably only be able to cause the “database is locked” though.
“Waiting for task to begin” is (I think) internal queueing where tasks are waiting for other tasks to finish.
schedulerQueueIds might be the queue. At least that’s where I saw a task waiting to get activeTask.

I have only ever used port 8200

This was useful, checking activetask was the the key to resolving this.
But making sure there was no active task was a greater challenge.

Ended up uninstalling, renaming db folder in appdata, reinstalling, importing backup job and then restoring. Which meant a db rebuild but also no active task and a successful start to the restore process.

Thank you for the tips!

1 Like