Backup Won't Pause?

Because of the problem I posted yesterday (I now have Google Drive and USB backups that are unreliable) I created a new backup of my files to the USB drive. I let it run overnight, but it’s going to take much longer than that of course. 2.0.5.1_beta_2020-01-18 on Windows 10

So I got up this morning and tried to pause it, so I can get some work done, because it’s making my laptop very slow. I paused it over an hour ago. The icon in my lower right Windows 10 system tray shows it paused. The web page shows it pausedl. But when I look at the sytem log, it’s been cranking out new dindex and dblock files like crazy, continuously.

First, why doesn’t it pause when it says it’s paused? Second, how can I reduce the priority or slow it down enough to get some work done?

Really frustrated. Thanks for any help!

What does Task Manager’s Performance tab think is busy? Often it’s the disk, but CPU is also possible.
I suppose networking could also be an issue, but that would only slow down your network-based things.

You can make Duplicati lower priority to leave more for the other things you might want to do with these:

As for pause, it seems to work in a few spots, but just in a few, so it might be best to try another method.
One that should work is a “Stop after current file”, seen by pushing the stop button at top of UI to do that.
There is also a “Stop now” shown, which stops faster but may cause issues (these got fixed in Canary).

I think the “after current file” idea means after the one you see on the screen, but there’s quite a distance before that actually gets processed then uploaded to destination. Still, should be faster than not stopping.

This new backup I created to my USB drive ran for three days, full backup, fine, no errors. Then ran it each night all week, did incrementals and was done within 30-45 mins as usual. Now last night I ran it and it seemed to want to do a full backup again. I ran all night and was clearly trying to do the whole laptop again (~500 gig).

I tried to stop it after next file. It continued to run for hours. Then I tried to stop it immediately. Hours later it’s still running.

What’s wrong with this? I know it’s beta, but I’m getting really frustrated, it doesn’t seem to do anything right.

If it’s still running, go to About --> Show log --> Live --> Information to see if it’s actually putting out files.
Backup will upload a mix of files with dblock and dindex in their names, without downloads in between.

If it’s already done (or even if not), your destination file dates can confirm/refute the “full backup” theory.

Viewing the log files of a backup job can provide information on the long-running backup, after it’s done.
Under Source Files you’ll see what it saw. Only new files and changed portions of files are uploaded.
Complete log has that information too (less nicely shown), and also BackendStatistics on uploads.

Stop after current file was pretty heavily tested, so it’s not clear why yours is not stopping better.
Stop now has worked for me, but has some bugs. Pause barely works. Work on fixing can be seen at:

Fix pause and resume, and check for cancel while uploading #3712 which might also help answer your

Basically, pause (like everything), is programmed into the system, keeping lots of considerations in mind.
Probably the pause is set up (so the UI thinks it’s paused), but not everything in the system respects it…