Backup is completely broken

Since the last backup, it has gone completely nuts.

Tried a regular backup, got something about 399 errors due to missing “remote files” (this is on another drive connected to the PC) and to run repair.
I clicked “Repair” and that errored.
I went into Advanced and tried rebuilding the database, and that errored.
I tried delete and rebuild, and that errored too, for good measure.
I explicitly ran the purge command and then deleted the database. Then I tried running the backup normally again, still errors referencing some 196 missing files.

Please let me know if I can fix this, and if there’s any specific log info I can dig out that’ll make this clearer, because all I was shown was a mass of file names or just empty error messages.

Edit: oh, and I’ve also tried running the backup with rebuild-missing-dblock-files enabled at some point through all this. Don’t see any difference.

Welcome to the forum @robholx

This result makes no sense. Are you sure you didn’t see a similar message about files, except extra, e.g.:

Found 14 remote files that are not recorded in local storage, please run repair

The database records what it thinks is in the backup. Deletion wipes its memory so old files are unknown.

Deletion also wipes valuable per-job logs. Did you save a copy of the database? If not, you might still have About --> Show log --> Error, and you might have some <job> --> Show log info from the recent attempts.

Knowing what happened originally might be lost. Is it possible the correct drive wasn’t connected? Would 399 missing files be all of them? You can probably just look on the drive now, to have Explorer count files, however that would leave the 196 to explain. If 399 were missing due to drive connect issue, backup after database delete should error 399 “not recorded in local storage”. There’s also that missing/extra question.

What error?

EDIT:

I’m interested in Recreate error because that’s often the best way to fix a database issue, if this is one, however any error info you can give on anything will help. I’m also not quite sure about the two “rebuild” tries. There’s no such button as far as I know. The options might not all be available (blue), but they are

image

Perhaps the first was the Repair button tried from this screen, and the second was the Recreate button?
The REPAIR command behavior is kind of confusing, because if DB is already deleted, it will re-create it.

There are other ways such as starting down the Direct restore from backup files (or maybe doing a small restore) to see whether the backup files are still intact, but what you really want is your database back up.