Backup Failure - Failed to process path

Getting a warning during a backup job.

2020-05-03 15:09:42 -04 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: /mnt/backup/full/Cold-Storage/virtual machines/Windows-1.vdi

Using 2.0.5. Been using it for a long time and everything’s worked quite well. This is only a problem with one file on one backup job. All other jobs are working fine.

The file is a virtual machine (virtualbox specifically) hard drive. 40gb. I believe this is the biggest single file I have in any of my backup jobs. Is there a size limit? If so, I couldn’t find anything specific. There’s plenty of space on the destination (which is OneDrive and unlimited).

This vdi file was just put in here to backup. This backup job was successful without errors/warnings prior to this file being included. This file has never been successfully backed up yet.

There’s another thread about a similar-ish issue. A suggestion was made to them to repair the database. I did a database repair on this backup job. Then I did a test. Both completed successfully. Then I tried to run the backup, it failed again. So far that’s 3 failures. All the same message. This is coming up as a “warning” not an “error.” Although I tried to do a restore and the file isn’t there, so it’s definitely an error.

Welcome to the forum!

What user is Duplicati running as? Does it have permission to access this file? Is this VM running at the time Duplicati tries to back up the VDI file?

Running as my own user. I did check the file permissions after the first failure. I have full access to read the files in that location. The permissions are the same as other files and folders that are working fine.

I didn’t explicitly mention the O/S I’m using. It’s Debian 10 64-bit.

And none of the backup attempts were when the VM was running. I made sure it VirtualBox wasn’t even running beforehand.

Just tried another backup after a month. Same warning. The vdi file isn’t being backed up successfully. Are there any issues with single files at this size (~20gb)? Any other possible issues?

Hello, sorry I missed your earlier reply!

No, there are no issues backing up large files. I back up many Virtual Machines myself that are 20GB and larger.

What type of disk is mounted at /mnt/backup ? Is it possible there is a read error on this file due to a fault on the storage? I’m curious if you can copy the file manually to a different location and if it will succeed.

/mnt/backup is a 3TB Western Digital (WDC WD30EZRX) physical hard drive. Formatted as ext4. Since there haven’t been issues with any other files on that drive I haven’t considered it a HD problem.

However, I copied the vdi file to a different hard drive. A 250GB something or the other drive formatted as NTFS. I created a brand new backup job and it worked just fine.

I think next I’ll try to copy the original vdi file to another location on the original hard drive and try that. Wondering maybe if there’s some funky fragmentation with it the Duplicati doesn’t like? The vdi file works fine when I do use it.

I copied the vdi file. Same hard drive this time. Just a duplicate. Ran the duplicati job again and it worked fine. No warnings or errors. Might be an issue with some bad sectors on the hard drive possibly. Working now, though.